当前位置: 代码迷 >> 综合 >> hdoj5489Removed Interval【lis】
  详细解决方案

hdoj5489Removed Interval【lis】

热度:30   发布时间:2023-12-17 08:29:36.0

Removed Interval

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1282    Accepted Submission(s): 437


Problem Description
Given a sequence of numbers  A=a1,a2,,aN , a subsequence  b1,b2,,bk  of  A  is referred as increasing if  b1<b2<<bk . LY has just learned how to find the longest increasing subsequence (LIS).
Now that he has to select  L  consecutive numbers and remove them from  A  for some mysterious reasons. He can choose arbitrary starting position of the selected interval so that the length of the LIS of the remaining numbers is maximized. Can you help him with this problem?

Input
The first line of input contains a number  T  indicating the number of test cases ( T100 ).
For each test case, the first line consists of two numbers  N  and  L  as described above ( 1N100000,0LN ). The second line consists of  N  integers indicating the sequence. The absolute value of the numbers is no greater than  109 .
The sum of N over all test cases will not exceed 500000.

Output
For each test case, output a single line consisting of “Case #X: Y”.  X  is the test case number starting from 1.  Y  is the maximum length of LIS after removing the interval.

Sample Input
  
   
2 5 2 1 2 3 4 5 5 3 5 4 3 2 1

Sample Output
  
   
Case #1: 3 Case #2: 1

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
#include<vector>
using namespace std;
const int maxn=100010;
int dp[maxn];
int li[maxn],ri[maxn],num[maxn];
/**********
定义li[i]为在前i位删除[x-l-1,x-1]的lis
ri[i]为从i到n的lis 
***********/
int BS(int n,int k){int l=0,r=n-1;while(l<=r){int mid=(l+r)>>1;if(dp[mid]>=k){r=mid-1;}else {l=mid+1;}}return l;
}
int main()
{int t,i,j,k=1,l,n;scanf("%d",&t);while(t--){scanf("%d%d",&n,&l);for(i=0;i<n;++i){scanf("%d",&num[i]);}int len=0,ans=0,pos;for(i=n-1;i>=0;--i){pos=BS(len,-num[i]);dp[pos]=-num[i];ri[i]=pos;if(pos==len)len++;}len=ans=0;memset(li,0,sizeof(li));for(i=0;i<n;++i){if(i+l<n){pos=BS(len,num[i+l]);li[i+l]=pos;}pos=BS(len,num[i]);dp[pos]=num[i];if(pos==len)len++;if(i<n-l)ans=max(ans,pos+1);}for(i=l;i<n;++i){ans=max(ans,ri[i]+li[i]+1);}printf("Case #%d: %d\n",k++,ans);}return 0;
}


  相关解决方案