当前位置: 代码迷 >> 综合 >> POJ 2184——Cow Exhibition【01背包、负值】
  详细解决方案

POJ 2184——Cow Exhibition【01背包、负值】

热度:13   发布时间:2023-12-16 23:10:26.0

题目传送门

变形的01背包,其实问题的本质是保证智商和幽默感和不为负数情况下的最大和。智商属性体积,幽默感属性为价值,问题转换为求体积大等于0时的体积、价值总和。

Description

“Fat and docile, big and dumb, they look so stupid, they aren’t much
fun…”

  • Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si’s and, likewise, the total funness TF of the group is the sum of the Fi’s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input

  • Line 1: A single integer N, the number of cows

  • Lines 2…N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.
    Output

  • Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and
TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value of TS+TF to 10, but the new value of TF would be negative, so it
is not allowed.

题意:

先给出 N 头奶牛(0<= N <= 100),每头牛都有一个聪明值Si,幽默值Fi。现在想从这些牛里面选出一些,让(聪明值总和TS+幽默值总和FS)最大,但是同时TS和FS又不能够为负值。

分析:

用dp[i]表示i这个质量下的最大价值,因为s[i]可能为负数,所以先预处理把所有的s[i]都加上100000,然后dp[100000]=0,其余dp[]=-inf.最后计算的时候从100000开始计算,如果dp[i]>=0,那么表示此时的f[i]>=0,之前的ans和dp[i]+i-100000相比较。注意,如果循环到某个i,s[i]<0,那么遍历次序是从小到大的,其实这和一维背包的原理有关,如果是二维的话,那么都可以用从小到大的方式循环,因为前面计算的值和后面的没有影响,但用一维写,前面可能会影响后面的,所以要避免这样的影响,所以才有顺序。

AC代码:

#include <iostream>
#include <vector>
#include <utility>
#include <cstring>
#include <algorithm>
#include <map>
#include <queue>
#include <stack>
#include <cstdio>
#include <fstream>
#include <set>
using namespace std;
typedef long long ll;
#define ios ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);const int MAXN = 1e5;
#define INF 0x3f3f3fint dp[2 * MAXN + 7];
int s[MAXN];
int f[MAXN];
int main() {
    int n;while (cin >> n) {
    for (int i = 1; i <= n; i++) {
    cin >> s[i] >> f[i];}fill(dp, dp + MAXN * 2 + 7, -INF);dp[MAXN] = 0;for (int i = 1; i <= n; i++) {
    if (s[i] < 0 && f[i] < 0)continue;if (s[i] > 0) {
    for (int j = MAXN * 2; j >= s[i]; j--) {
    if (dp[j - s[i]] > -INF)dp[j] = max(dp[j], dp[j - s[i]] + f[i]);}}else {
    for (int j = 0; j <= MAXN * 2 + s[i]; j++) {
    if (dp[j - s[i]] > -INF)dp[j] = max(dp[j], dp[j - s[i]] + f[i]);}}}int ans = -INF;for (int i = MAXN; i <= MAXN * 2; i++) {
    if (dp[i] > 0)ans = max(ans, dp[i] + i - MAXN);}if (ans == -INF)ans = 0;cout << ans << endl;}return 0;
}