当前位置: 代码迷 >> 综合 >> HDU 1059——Dividing【多重背包 二进制优化】
  详细解决方案

HDU 1059——Dividing【多重背包 二进制优化】

热度:89   发布时间:2023-12-16 23:09:24.0

题目传送门

简单多重背包,体积为硬币数,价值为币值,可用二进制处理成01背包求解,可用30对num进行优化。


Problem Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.


Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0’’. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0’’; do not process this line.


Output

For each colletcion, output Collection #k:'', where k is the number of the test case, and then eitherCan be divided.’’ or ``Can’t be divided.’’.

Output a blank line after each test case.


Sample Input

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0


Sample Output

Collection #1:
Can’t be divided.

Collection #2:
Can be divided.


题意:

有价值1、2、3、4、5、6的硬币各多少个,判断能否把他们分成价值相等的两部分。


分析:

  • 简单的多重背包
  • 二进制优化

AC代码:

#include <iostream>
#include <vector>
#include <utility>
#include <cstring>
#include <algorithm>
#include <map>
#include <queue>
#include <stack>
#include <cstdio>
#include <fstream>
#include <set>
using namespace std;
typedef long long ll;
#define ios ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);#define INF 0x3f3f3fconst int MAX_N = 50000 + 7;
const int MAX_W = 120005 + 7;int dp[MAX_W];
int w[MAX_N];
int main() {
    int s[7];int count = 0;while (cin >> s[1] >> s[2] >> s[3] >> s[4] >> s[5] >> s[6], s[1] || s[2] || s[3] || s[4] || s[5] || s[6]) {
    memset(dp, 0, sizeof dp);int k = 0;int sum = 0;for (int i = 1; i <= 6; i++) {
    sum += s[i] * i;for (int a = 1; a <= s[i]; a *= 2) {
    w[k++] = i * a;s[i] -= a;}if (s[i] > 0)w[k++] = i * s[i];}for (int i = 0; i < k; i++)for (int j = sum / 2; j >= w[i]; j--) {
    dp[j] = max(dp[j - w[i]] + w[i], dp[j]);}cout << "Collection #" << ++count << ":" << endl;if (2 * dp[sum / 2] == sum)cout << "Can be divided." << endl;elsecout << "Can't be divided." << endl;cout << endl;}return 0;
}