当前位置: 代码迷 >> 综合 >> HDU 1520——Anniversary party【树形DP】
  详细解决方案

HDU 1520——Anniversary party【树形DP】

热度:46   发布时间:2023-12-16 23:05:44.0

题目传送门


Problem Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.


Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0


Output

Output should contain the maximal sum of guests’ ratings.


Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0


Sample Output

5


题意:

  • 翻译: 有个公司要举行一场晚会。为了让到会的每个人不受他的直接上司约束而能玩得开心,公司领导决定:如果邀请了某个人,那么一定不会再邀请他的直接的上司,但该人的上司的上司,上司的上司的上司……都可以邀请。已知每个人最多有唯一的一个上司。
    已知公司的每个人参加晚会都能为晚会增添一些气氛,求一个邀请方案,使气氛值的和最大。

  • 在一个有根树上每个节点有一个权值,每相邻的父亲和孩子只能选择一个,问怎么选择总权值之和最大。


题解:

  • 树形DP的一般步骤是从根节点往下遍历,一直遍历到叶子节点,然后从叶子节点向上回溯,将信息不断的向上传递,再次传递到根节点。同时树形DP的状态转移方程也是比较容易的,得益于树这种完美的结构。
  • dp[i][0]:表示不选择节点i的时候最大的权值,dp[i][1]:表示选择节点i的时候,我们可以得到的最大的权值。
  • 状态转移方程:
    dp[father][0] += max(dp[son][1],dp[son][0]); 当我们不选择父亲节点是,我们需要选择儿子节点中最大的那一种
    dp[father][1] += dp[son][0]; 我们选择父亲节点的时候,我们只有一种选择,就是不去选择儿子节点

AC-Code:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<sstream>
#include<vector>
#include<stack>
#include<queue>
#include<cmath>
#include<map>
#include<set>
using namespace std;
typedef long long ll;
typedef pair<int,int> pll;
const int INF = 0x3f3f3f3f;
const int MAXN = 10004 + 5;ll dp[MAXN][2];
vector<int>vec[MAXN];
int a[MAXN];
int pre[MAXN];
void dfs(int x){
    dp[x][0] = 0;dp[x][1]=a[x];for(int i = 0; i < vec[x].size(); i++){
    dfs(vec[x][i]);dp[x][0] += max(dp[vec[x][i]][0], dp[vec[x][i]][1]);dp[x][1] += dp[vec[x][i]][0];}
}
int main(){
    int n; int x, y;while(cin >> n){
    memset(dp, 0, sizeof(dp));for(int i = 1; i <= n ; i++){
    cin >> a[i];vec[i].clear();pre[i]=-1;}while(cin >> x >> y){
    if(x ==0 && y == 0)break;vec[y].push_back(x);pre[x] = y;}int root = 1;                          while(pre[root] != -1)root = pre[root];dfs(root);ll ans = max(dp[root][0], dp[root][1]);cout << ans << endl;       }    return 0;
}