当前位置: 代码迷 >> 综合 >> hdu 1087 Super Jumping! Jumping! Jumping! 【动规】
  详细解决方案

hdu 1087 Super Jumping! Jumping! Jumping! 【动规】

热度:97   发布时间:2023-12-16 06:05:56.0

题目

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

在这里插入图片描述
The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

输入

Input contains multiple test cases. Each test case is described in a line as follow:
N v a l u e 1 v a l u e 2 … v a l u e N N value_1 value_2 …value_N Nvalue1?value2?valueN?
It is guarantied that N is not more than 1000 and all v a l u e i value_i valuei? are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

输出

For each case, print the maximum according to rules, and one line one case.

样例输入

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

样例输出

4
10
3

题目分析

本题为求解一个单调递增的数列的所有元素之和的最大值,可采取动态规划的方法,将所有递增序列求解出,然后各集合元素求和,得出最大的值。此处采用了从后向前遍历,依次确定该位置走到end位置可以获得的最大分数。

代码

#include<iostream>
using namespace std;int a[1005];//记录位置的数值
int score[1005];//记录该位置到end处的最大分数
int mark,max_c,n,flag;void max_score(int t)//计算当前位置到end的最大分数
{
    mark=score[t];//标记当前位置分数,即是其本身flag=0;//判断该位置后,是否存在更大的数for(int i=t;i<=n;++i){
    if(a[t]<a[i])//判定数值大小if(mark<score[i])//寻找后面可跳跃位置中最大分数{
    flag=1;//存在mark=score[i];}}if(flag)score[t]+=mark;
}int main()
{
    while(scanf("%d",&n) && n){
    for(int i = 1;i<=n;++i){
    scanf("%d",&a[i]);score[i]=a[i];}for(int i = n;i>0;--i)max_score(i);max_c=0;for(int i = 1;i<=n;++i)if(max_c<score[i])max_c=score[i];//最大分数printf("%d\n",max_c);}return 0;
}

运行结果

在这里插入图片描述

题目链接

http://acm.hdu.edu.cn/showproblem.php?pid=1087

  相关解决方案