当前位置: 代码迷 >> 综合 >> [PAT A1002]A+B for Polynomials
  详细解决方案

[PAT A1002]A+B for Polynomials

热度:19   发布时间:2023-12-15 06:18:02.0

[PAT A1002]A+B for Polynomials

题目描述

1002 A+B for Polynomials (25 分)This time, you are supposed to find A+B where A and B are two polynomials.

输入格式

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N?1?? a?N?1???? N?2?? a?N?2???? … N?K?? a?N?K????
where K is the number of nonzero terms in the polynomial, N?i?? and a?N?i???? (i=1,2,?,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N?K??<?<N?2??<N?1??≤1000.

输出格式

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

输入样例

2 1 2.4 0 3.2
2 2 1.5 1 0.5

输出样例

3 2 1.5 1 2.9 0 3.2

解析

简单题,就是输入两个多项式,然后输出他们相加之后的结果

#include<iostream>
using namespace std;
double num1[1010] = {
     0 }, num2[1010] = {
     0 };
int main()
{
    int n;int cnt = 0;scanf("%d", &n);for (int i = 0; i < n; i++) {
    int a;double b;scanf("%d %lf", &a, &b);num1[a] = b;}scanf("%d", &n);for (int i = 0; i < n; i++) {
    int a;double b;scanf("%d %lf", &a, &b);num2[a] = b;}for (int i = 0; i < 1010; i++) {
    if (num1[i] != 0 || num2[i] != 0) {
    num1[i] += num2[i];if (num1[i] != 0) cnt++;   //注意这里必须要判断是否为零,因为两个互为相反数的项相加为零,这项是没有的}}if (cnt == 0) printf("0");else {
    printf("%d ", cnt);for (int i = 1009; i >= 0; i--) {
    if (num1[i] != 0) {
    printf("%d %.1f", i, num1[i]);cnt--;if (cnt != 0)printf(" ");}}}return 0;
}

水平有限,如果代码有任何问题或者有不明白的地方,欢迎在留言区评论;也欢迎各位提出宝贵的意见!