当前位置: 代码迷 >> 综合 >> PAT---B1028. 人口普查(20)
  详细解决方案

PAT---B1028. 人口普查(20)

热度:73   发布时间:2023-12-15 04:09:26.0

题目要求:
某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数N,取值在(0, 105];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20
输出样例:
3 Tom John

参考代码:

#include <iostream>
#include <stdio.h>
using namespace std;
typedef struct birthday
{string name;int year;int month;int day;
}birthday;
birthday old,young,oldest,youngest;
bool identify_more(birthday a,birthday b)  //
{if(a.year!=b.year)return a.year>=b.year;else if(a.month!=b.month)return a.month>=b.month;elsereturn a.day >=b.day;
/*if(a.year>b.year)return true; //没有超过左边界else if((a.year==b.year)&&(a.month>b.month))return true;else if((a.year==b.year)&&(a.month==b.month)&&(a.day>=b.day))return true;elsereturn false;*/
}
bool identify_less(birthday a,birthday b)//
{if(a.year!=b.year)return a.year<=b.year;else if(a.month!=b.month)return a.month<=b.month;elsereturn a.day <=b.day;
/*if(a.year<b.year)return true; //没有超过左边界else if((a.year==b.year)&&(a.month<b.month))return true;else if((a.year==b.year)&&(a.month==b.month)&&(a.day<=b.day))return true;elsereturn false;
*/
}
void init()
{young.year = 2014;young.month=9;young.day=6;old.year=1814;old.month=9;old.day=6;
}
bool identify(birthday a)
{if((identify_less(a,young))&&(identify_more(a,old)))return true;elsereturn false;
}
int main()
{int count_true = 0;int N;cin >> N;int S=N;int i=1;birthday *pbirthday = new birthday[N+1];init();while(N--){cin >>pbirthday[i].name;scanf("%d/%d/%d/",&pbirthday[i].year,&pbirthday[i].month,&pbirthday[i].day);i++;}oldest = pbirthday[1];youngest = pbirthday[1];for(int i=1;i<=S;i++){if(identify(pbirthday[i])){count_true++;if(identify_less(pbirthday[i],oldest))oldest = pbirthday[i];if(identify_more(pbirthday[i],youngest))youngest = pbirthday[i];}}if(count_true == 0 )cout << "0";elsecout << count_true<<" "<<oldest.name<<" "<<youngest.name;delete [] pbirthday;return 0;
}