当前位置: 代码迷 >> 综合 >> 1150 Travelling Salesman Problem (25 分)图论,旅行售票员问题
  详细解决方案

1150 Travelling Salesman Problem (25 分)图论,旅行售票员问题

热度:15   发布时间:2023-12-14 01:16:24.0

The “travelling salesman problem” asks the following question: “Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?” It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from “https://en.wikipedia.org/wiki/Travelling_salesman_problem”.)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:
n C?1 C2 … Cn
where n is the number of cities in the list, and C?i’s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

TS simple cycle if it is a simple cycle that visits every city;
TS cycle if it is a cycle that visits every city, but not a simple cycle;
Not a TS cycle if it is NOT a cycle that visits every city.
Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

题意:这个是一个旅行售票员问题,给定一个城市列表和每对城市之间的距离,访问每个城市并返回原城市的最短可能路径是什么?
给出k个查询,每个查询里面输入了城市的信息,判断是哪一种类型的环路:是旅行商环路,简单旅行商环路,还是非旅行商环路。
思路:用一个二维矩阵存储城市和城市之间距离的信息,用一个全局变量ans和ansid分别记载最短距离和测试次数索引。如果不是旅行商环路的话,是不能算进比较最短距离的情况的。分下面几种情况(非旅行商环路要分两种情况写):
非旅行商环路:线路中有两点不可达(无法计算距离),第一个结点与最后一个结点不同,路径没有访问图中所有的顶点。出现不可达的情况下直接NA,出现后两种情况,是Not a TS cycle,但是要计算距离
简单旅行商环路:只要判断查询列出来的顶点数是不是图中所列的顶点数的n+1即可判断为这种类型,因为如果出现重复顶点已经被上一种情况排除了
旅行商环路:剩下的就全是这种类型

#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<cctype>
#include<cstdlib>
#include<ctime>
#include<unordered_map>using namespace std;int e[210][210];
int n,m,k,ansid;
int ans = 99999999;void check(int index) {
    int cnt;int flag = 1;int sum = 0;set<int> s;scanf("%d",&cnt);vector<int> v(cnt);for(int i = 0;i < cnt;i++) {
    scanf("%d",&v[i]);s.insert(v[i]);}for(int i = 0;i < cnt - 1;i++) {
    if(e[v[i]][v[i + 1]] == 0) {
    flag = 0;}sum += e[v[i]][v[i + 1]];} if(flag == 0) {
    printf("Path %d: NA (Not a TS cycle)\n",index);} else if(v[0] != v[cnt - 1] || s.size() != n) {
    printf("Path %d: %d (Not a TS cycle)\n",index,sum);} else if(cnt != n + 1) {
    printf("Path %d: %d (TS cycle)\n",index,sum);if(sum < ans) {
    ans = sum;ansid = index;}} else {
    printf("Path %d: %d (TS simple cycle)\n",index,sum);if(sum < ans) {
    ans = sum;ansid = index;}}
}int main() {
    scanf("%d%d",&n,&m);for(int i = 1;i <= m;i++) {
    int t1,t2,dist;scanf("%d%d%d",&t1,&t2,&dist);e[t1][t2] = e[t2][t1] = dist;}	scanf("%d",&k);for(int i = 1;i <= k;i++) {
    check(i);}printf("Shortest Dist(%d) = %d\n",ansid,ans);return 0;
}
  相关解决方案