当前位置: 代码迷 >> 综合 >> 1007 Maximum Subsequence Sum (25 分)动态规划求最大上升序列和
  详细解决方案

1007 Maximum Subsequence Sum (25 分)动态规划求最大上升序列和

热度:38   发布时间:2023-12-14 01:15:35.0

Given a sequence of K integers { N?1, N2, …, NK}. A continuous subsequence is defined to be { N?i, Ni+1, …, Nj} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题意:输入n个序列,求最大上升序列,输出最大和和起始数字和结束数字
思路:运用dp,先求出最大和,即求出了结束数字,然后再从后往前推只要累加的和等于最大值说明遍历到的那个数字就是起始数字。但是这样写还有一个点过不去,只拿了21分,
21分题解:

#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>using namespace std;int main() {
    int n;scanf("%d",&n);vector<int> v(n);vector<int> dp(n);for(int i = 0;i < n;i++) {
    scanf("%d",&v[i]);}dp[0] = v[0];for(int i = 1;i < n;i++) {
    dp[i] = max(v[i],dp[i - 1] + v[i]);}int start = 0,end = 0;for(int i = 1;i < n;i++) {
    if(dp[i] > dp[end]) {
    end = i;}}int sum = 0;for(int i = end;i >= 0;i--) {
    sum += v[i];if(sum == dp[end]) {
    start = i;break;}}//判断最大和小于0 if(dp[end] < 0) {
    dp[end] = 0;} printf("%d %d %d\n",dp[end],v[start],v[end]);return 0;
} 

柳神题解:

#include <iostream>
#include <vector>
using namespace std;
int main() {
    int n;scanf("%d", &n);vector<int> v(n);int leftindex = 0, rightindex = n - 1, sum = -1, temp = 0, tempindex = 0;for (int i = 0; i < n; i++) {
    scanf("%d", &v[i]);temp = temp + v[i];if (temp < 0) {
    temp = 0;tempindex = i + 1;} else if (temp > sum) {
    sum = temp;leftindex = tempindex;rightindex = i;}}if (sum < 0) sum = 0;printf("%d %d %d", sum, v[leftindex], v[rightindex]);return 0;
}
  相关解决方案