当前位置: 代码迷 >> 综合 >> 1009 Product of Polynomials (25 分)多项式乘法
  详细解决方案

1009 Product of Polynomials (25 分)多项式乘法

热度:72   发布时间:2023-12-14 01:15:22.0

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 aN1 N2 aN2 ... N?K aNK

?? where K is the number of nonzero terms in the polynomial, N?i and a?Ni(i=1,2,?,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤NK<?<N2<N1≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

题意:给出两组数,每组有n对数,求多项式乘法的和
思路:开一个大小为2010的数组,第一次先把n对数输入进来,然后存到数组中,第二次输入数的时候进行a[j + c]+=a[j]*d,最后求出ans数组中一共有多少不为0的数,再将这些数按照索引从大到小排列输出。

#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>using namespace std;double a[2010] = {
    0},ans[2010] = {
    0};int main() {
    int m,n;scanf("%d",&m);int c;double d;for(int i = 0;i < m;i++) {
    scanf("%d%lf",&c,&d);a[c] = d;}scanf("%d",&n);for(int i = 0;i < n;i++) {
    scanf("%d%lf",&c,&d);for(int j = 0;j < 2005;j++) {
    ans[j + c] += a[j] * d;}}int cnt = 0;for(int i = 0;i < 2005;i++) {
    if(ans[i] != 0) {
    cnt++;}}printf("%d",cnt);for(int i = 2005;i >= 0;i--) {
    if(ans[i] != 0) {
    printf(" %d %.1lf",i,ans[i]);}}return 0;
}
  相关解决方案