当前位置: 代码迷 >> 综合 >> POJ-3616 Milking Time 鶸的DP解题报告
  详细解决方案

POJ-3616 Milking Time 鶸的DP解题报告

热度:1   发布时间:2023-12-12 14:16:06.0

题目:

Milking Time
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12358   Accepted: 5242

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

题意:有m个时间段,每段时间都有开始时间,结束时间,产生价值三个属性。John可以选择一些时间段来产生价值,当然选择的时间段时间不能有重复,并且进行完一个时间段的工作之后,他必须休息r时间。求从这m个时间段中产生价值的最大值。

思路:首先要将所有时间段按照开始时间进行从小到大的排序。

之后定义dp[i]为:假设第i个时间段进行产奶时时,产生价值的总和的最大值。

状态转移方程为: dp[i] = max(dp[i] , dp[i]+list[j].value) ;( j<i , list[j].end+r<=list[i].start)

也就是说如果当前时间时间段产奶,产生价值的最大值为当前时间段产生的价值加上之前时间段所能产生的最大值。

而结果自然是所有假设中的最大值。

代码:

#include<cstdio>  
#include<cstdlib>  
#include<cmath>  
#include<cstring>  
#include<iostream>  
#include<algorithm>  
#include<queue>  
#include<map>  
#include<stack> 
#include<set>
#define sd(x) scanf("%d",&x)
#define ss(x) scanf("%s",x)
#define sc(x) scanf("%c",&x)
#define sf(x) scanf("%f",&x)
#define slf(x) scanf("%lf",&x)
#define slld(x) scanf("%lld",&x)
#define me(x,b) memset(x,b,sizeof(x))
#define pd(d) printf("%d\n",d);
#define plld(d) printf("%lld\n",d);
#define eps 1.0E-8
// #define Reast1nPeacetypedef long long ll;using namespace std;const int INF = 0x3f3f3f3f;struct fj{int s,e;int v;
}lis[1010];bool cmp(fj x , fj y){if(x.s == y.s){return x.e < y.e;}return x.s < y.s;
}int dp[1010];int main(){
#ifdef Reast1nPeacefreopen("in.txt", "r", stdin);freopen("out.txt", "w", stdout);
#endifios::sync_with_stdio(false);int n,m,r;cin>>n>>m>>r;for(int i = 0 ; i<m ; i++){cin>> lis[i].s >> lis[i].e >> lis[i].v;}sort(lis , lis+m ,  cmp);int maxn = 0;for(int i = 0 ; i<m ; i++){dp[i] = lis[i].v;for(int j = 0 ; j<i ; j++){if(lis[j].e+r <= lis[i].s){dp[i] = max(dp[i] , dp[j]+lis[i].v);}}maxn = max(dp[i] , maxn);}cout<<maxn<<endl;return 0;
}
  相关解决方案