当前位置: 代码迷 >> 综合 >> POJ--3641--快速幂运算模板,素数筛
  详细解决方案

POJ--3641--快速幂运算模板,素数筛

热度:40   发布时间:2023-12-12 06:38:34.0
//pow(x,n)%mod
typedef long long ll;
ll mod_pow(ll x,ll n,ll mod){//时间复杂度O(logn) ll ans=1;while(n>0){if(n&1)ans=ans*x%mod;x=x*x%mod;n>>=1;}return ans;
} 

素数筛,但是在大多数时候不用,而是及时判断

const int MAX=10000010;
bool prime_8[MAX];
void prime(){for(int i=2;i<=MAX;i++)for(int j=2;j*j<=i;j++)if(i%j==0){prime_8[i]=true;//true表示不是素数//continue;                }
}
//在这之前:memset(prime,false,sizeof(prime));

题目:POJ3641 

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input
3 2
10 3
341 2
341 3
1105 2
1105 3
0 0
Sample Output
no
no
yes
no
yes
yes

思路:以上两个模板

#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
typedef long long ll;
const ll  MAX=1000000000+1;
bool prime_8[MAX]; 
//素数筛 
bool prime(int p){for(int i=2;i<=sqrt(p);i++){if(p%i==0)return 0;}return 1;} 
//pow(x,n)%mod
ll mod_pow(ll x,ll n,ll mod){//时间复杂度O(logn) ll ans=1;while(n>0){if(n&1)ans=ans*x%mod;x=x*x%mod;n>>=1;}return ans;
} 
int main(){int p,a;
//	prime();//线性时间,但是还是消耗时间 ,改为及时判断 while(1){ cin>>p>>a;//a^p=a(mod p)并且p不是素数 -----a^(p-1) MOD p=1if(p==0&&a==0)break;if(prime(p)==1){cout<<"no"<<endl;}else{if(mod_pow(a,p,p)==a%p)cout<<"yes"<<endl;elsecout<<"no"<<endl;}}
}