当前位置: 代码迷 >> 综合 >> POJ--3579--查找第k大的值
  详细解决方案

POJ--3579--查找第k大的值

热度:57   发布时间:2023-12-12 06:36:09.0

Given N numbers, X1, X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i  j  N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, ... , XN, ( Xi ≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input
4
1 3 2 4
3
1 10 2
Sample Output
1
8

常规思路一超时间:(超时)

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
const long long MAX=10000+1;
int n;
long long a[MAX],b[MAX/2*MAX];//数组极容易溢出 
int main(){while(scanf("%d",&n)!=EOF){long long cnt=0; for(int i=0;i<n;i++)cin>>a[i];for(int i=0;i<n;i++)for(int j=i+1;j<n;j++)//这里已经超时!!!O(N^2) b[cnt++]=fabs((double)(a[j]-a[i]));//新序列的长度是C(n,2),即为cnt; sort(b,b+cnt);//O(log(n))if(cnt%2==0)cout<<b[cnt/2-1]<<endl;elsecout<<b[cnt/2]<<endl; } 
} 

思路二:具体见代码注释即可;

 

Status Accepted
Time 563ms
Memory 224kB
Length 756
Lang C++
Submitted 2020-02-01 15:30:24
Shared  
RemoteRunId 21289534
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1111111;
int n;
int x[maxn];
long long m;
bool C(int mid){long long cnt=0;for(int i=0;i<n;i++)cnt+=x+n-lower_bound(x+i+1, x+n, x[i]+mid);//lower_bound返回第一个大于等于xi+mid值的下标,原数列在其后面的都比xi+mid大//cnt计算所有差值比mid大的原数列组合个数return cnt<=m/2;      //等于号是因为,cnt计算的是比mid大的个数
}
int main() {while(~scanf("%d", &n)){for(int i=0;i<n;i++)scanf("%d",&x[i]);sort(x,x+n);m = n*(n-1)/2;      //新数列的个数就是C_N_2(组合数),N是原数列的个数int L=0,R=*max_element(x,x+n); //r为最大元素while(R-L>1){int mid=(L+R)/2;if(C(mid)) R=mid;else L=mid;}printf("%d\n",L);}
}