当前位置: 代码迷 >> 综合 >> HDU--1861--记忆化查找
  详细解决方案

HDU--1861--记忆化查找

热度:13   发布时间:2023-12-12 06:17:06.0

现有公园游船租赁处请你编写一个租船管理系统。当游客租船时,管理员输入船号并按下S键,系统开始计时;当游客还船时,管理员输入船号并按下E键,系统结束计时。船号为不超过100的正整数。当管理员将0作为船号输入时,表示一天租船工作结束,系统应输出当天的游客租船次数和
平均租船时间。
注意:由于线路偶尔会有故障,可能出现不完整的纪录,即只有租船没有还船,或者只有还船没有租船的纪录,系统应能自动忽略这种无效纪录。

Input

测试输入包含若干测试用例,每个测试用例为一整天的租船纪录,格式为
船号(1~100) 键值(S或E) 发生时间(小时:分钟)
每一天的纪录保证按时间递增的顺序给出。当读到船号为-1时,全部输入结束,相应的结果不要输出。

Output

对每个测试用例输出1行,即当天的游客租船次数和平均租船时间(以分钟为单位的精确到个位的整数时间)。

Sample Input
1 S 08:10
2 S 08:35
1 E 10:00
2 E 13:16
0 S 17:00
0 S 17:00
3 E 08:10
1 S 08:20
2 S 09:00
1 E 09:20
0 E 17:00
-1
Sample Output
2 196
0 0
1 60

思路:模拟+记忆化统计;

#include<cstdio>  
#include<cstring>  
#include<cmath>
#include<iostream>
using namespace std;
const int maxa=1e2+10;
int time[maxa],vis[maxa];
int cnt; 
double sum; 
int main(){  int n,h,m;  char c;     cnt=0;  memset(time,0,sizeof(time)); memset(vis,0,sizeof(vis));while(scanf("%d",&n)!=EOF&&(n!=-1))  {  getchar(); scanf("%c%d:%d",&c,&h,&m);//不是以字符串的方式输入 if(n==0){  double temp=0;if(cnt!=0)temp=floor(double(sum)/cnt+0.5);		printf("%d %d\n",cnt,(int)temp);sum=0;  cnt=0;  memset(time,0,sizeof(time));			memset(vis,0,sizeof(vis));continue;  }  if(c=='S'){  time[n]=h*60+m;  vis[n]=1;  }else{  if(vis[n]){//当前的船没有被租用 sum+=h*60+m-time[n]; cnt++;  }  }  }  return 0;  
}