当前位置: 代码迷 >> 综合 >> G - Median POJ - 3579(二分)
  详细解决方案

G - Median POJ - 3579(二分)

热度:9   发布时间:2023-12-07 00:26:11.0

G - Median POJ - 3579

Given N numbers, X1, X2, … , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i < j ≤ N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!
Note in this problem, the median is defined as the (m/2)-th smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of m = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, … , XN, ( Xi ≤ 1,000,000,000 3 ≤ N ≤ 1,00,000 )
Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8

题意
求数列1 ~ N 的任意两个差的绝对值的 第中间个 的值

题解

1 ~ N 的任意两个差 有k = (N - 1) * N / 2 个数字 所以不可能暴力。
所以用二分求 第 (k + 1) / 2个。

check 函数 判断 差小于 mid 的个数 是否小于 k 个。

#include <iostream>
#include <cmath>
#include <algorithm>
#include <string>
#include <cstdio>
#include <set>
#include <iomanip>
#include <vector>
using namespace std;
int const MAX = 1e5 +7;
long long N;
int k;
long long x[MAX];
bool check (int mid) {
    int sum = 0;for(int i = 0; i < N; i++) {
    int cnt = upper_bound(x, x + N, x[i] + mid) - x;sum += (cnt - i - 1);}if(sum >= k) return 1;return 0;
}
int main() {
    while(scanf("%lld", &N) != EOF) {
    for(int i = 0; i < N; i++) {
    scanf("%lld", &x[i]);}k = (N - 1) * N / 2;k = (k + 1) / 2 ;sort(x, x + N);int L = 0, R = x[N - 1] - x[0];while(R - L > 1) {
    int mid = (L + R) / 2;if(check(mid)) R = mid;else L = mid;}printf("%d\n", R);}
}
  相关解决方案