当前位置: 代码迷 >> 综合 >> 1044?火星数字?(20分)
  详细解决方案

1044?火星数字?(20分)

热度:21   发布时间:2023-12-06 21:45:52.0

 

火星人是以 13 进制计数的:

  • 地球人的 0 被火星人称为 tret。
  • 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13

 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<string>using namespace std;
const int maxn=10010;
const int N=10;string s;
int len;string l[13]={"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"};
string h[13]={"###","tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou"};void i2s(int t){//115  elo nov//8.....11int b=t/13,a=t%13;if(b)  cout<<h[b];if(a && b) putchar(' ');if(a || !t ) cout<<l[a]; //因为最大为168 < 13^2 所以进制转换后最多存在两位//即低位a和高位b   //b==0 a!=0   b==0 a==0   b!=0 a!=0  b!=0 a==0  //0%a=0 零对任何数求余都等于零 
}void s2i(){//elo nov  115//8*13 + 11int t1=0,t2=0;string s1,s2;s1=s.substr(0,3);if(len>4) s2=s.substr(4);  for(int i=1;i<13;i++){//	 	if( s1 == h[i] || s1 == l[i]) t1 = i;
//	 	if( s2 == l[i] ) t2 = i;
//这样就错了 涉及到 权重的问题if( s1==h[i] )  t1=i;if( s2==l[i] || s1==l[i]) t2=i;}cout<< t1 * 13 + t2; 
}int main(){int n;cin>>n;getchar();for(int i=0; i<n;i++){getline(cin,s);len=s.length();if( isdigit(s[0]) )i2s(stoi(s));  // i2s  168 < 13^2 两位数 elses2i();cout<<endl; }return 0;
}