当前位置: 代码迷 >> 综合 >> 【HDU - 3579】Hello Kiki(拓展中国剩余定理)
  详细解决方案

【HDU - 3579】Hello Kiki(拓展中国剩余定理)

热度:10   发布时间:2023-12-06 19:38:49.0

One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing "门前大桥下游过一群鸭,快来快来 数一数,二四六七八". And then the cashier put the counted coins back morosely and count again... 
Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number of the remaining coins Ai on her note. 
One day Kiki's father found her note and he wanted to know how much coins Kiki was counting.

Input

The first line is T indicating the number of test cases. 
Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line. 
All numbers in the input and output are integers. 
1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi

Output

For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1. 

Sample Input

2
2
14 57
5 56
5
19 54 40 24 80
11 2 36 20 76

Sample Output

Case 1: 341
Case 2: 5996

思路:(博客1,博客2)

拓展中国剩余定理,自己因为在ex_gcd上少写了&,一直样例过不了。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<string>
#include<vector>
using namespace std;
typedef long long ll;
const int MAX=400000;
const ll mod=1000000007;
ll ex_gcd(ll a,ll b,ll &x,ll &y)
{if(!b){x=1;y=0;return a;}ll g=ex_gcd(b,a%b,y,x);y-=a/b*x;return g;
}
ll a[MAX],m[MAX];
ll ex_crt(ll n)
{ll c=a[0],l=m[0],x,y;for(int i=1;i<n;i++){ll d=ex_gcd(l,m[i],x,y);if((a[i]-c)%d)return -1;int tt=m[i]/d;x=(a[i]-c)/d*x%(m[i]/d);c+=l*x;l=l/d*m[i];c%=l;}return (c+l)%l?(c+l)%l:l;
}
int main()
{int t,cas=1;cin>>t;int n,ai;while(t--){scanf("%d",&n);ll ans;for(int i=0;i<n;i++)scanf("%lld",&m[i]);for(int i=0;i<n;i++)scanf("%lld",&a[i]); ll sum=ex_crt(n);printf("Case %d: %lld\n",cas++,sum);}return 0;
}

java:

import java.util.Scanner;
import java.math.BigInteger;
public class Main {static int MAX=400000;static long mod=1000000007;static long a[]=new long[MAX];static long m[]=new long[MAX];static long x,y;static long ex_gcd(long a,long b){if(b==0){x=1L;y=0L;return a;}long g=ex_gcd(b,a%b);long tmp=x;x=y;y=tmp-a/b*y;return g;}static long ex_crt(long n){long c=a[0],l=m[0];for(int i=1;i<n;i++){long d=ex_gcd(l,m[i]);if((a[i]-c)%d!=0)return -1;x=(a[i]-c)/d*x%(m[i]/d);c+=l*x;l=l/d*m[i];c%=l;}if ((c+l)%l!=0)return (c+l)%l;elsereturn l;}public static void main(String[] args) {// TODO Auto-generated method stubint t,cas=1;Scanner rd=new Scanner(System.in);t=rd.nextInt();int n,ai;while(t>0){t--;n=rd.nextInt();for(int i=0;i<n;i++)m[i]=rd.nextLong();for(int i=0;i<n;i++)a[i]=rd.nextLong(); long sum=ex_crt(n);System.out.println("Case "+cas+": "+sum);cas++;}}private static BigInteger BigInteger(int i) {// TODO Auto-generated method stubreturn null;}}
/*
2
2
14 57
5 56
5
19 54 40 24 80
11 2 36 20 76*/