当前位置: 代码迷 >> 综合 >> 集训队专题(2)1001 Fibonacci
  详细解决方案

集训队专题(2)1001 Fibonacci

热度:64   发布时间:2023-12-06 03:47:08.0

Fibonacci

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 53   Accepted Submission(s) : 41
Problem Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn ? 1 + Fn ? 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.


Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number ?1.


Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).


Sample Input
  
   
0 9 999999999 1000000000 -1

Sample Output
  
   
0 34 626 6875

Source
PKU

最基础的矩阵快速幂用法,题目已经给出了具体的公式那就不在赘述,代码:

#include <cstdio>
#include <iostream>
#define MOD 10000
using namespace std;
struct matrix
{int m[2][2];
}ans,base;
matrix multi(matrix a,matrix b)
{matrix tmp;for(int i=0; i<2; i++){for(int j=0; j<2; j++){tmp.m[i][j] = 0;for(int k=0; k<2; k++)tmp.m[i][j] = (tmp.m[i][j] + a.m[i][k]*b.m[k][j]) % MOD;}}return tmp;
}
int fast_mod(int n)
{base.m[0][0] = base.m[0][1] = base.m[1][0] = 1;base.m[1][1] = 0;ans.m[0][0] = ans.m[1][1] = 1;ans.m[0][1] = ans.m[1][0] = 0;while(n){if(n&1) ans = multi(ans,base);base = multi(base,base);n >>= 1;}return ans.m[0][1];
}
int main()
{int n;while(scanf("%d",&n)&&n!=-1){printf("%d\n",fast_mod(n));}return 0;
}