当前位置: 代码迷 >> 综合 >> POJ 1733 Parity【扩展域并查集】
  详细解决方案

POJ 1733 Parity【扩展域并查集】

热度:91   发布时间:2023-11-28 06:56:30.0

题目链接:http://poj.org/problem?id=1733

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

题解:P190。如果我们用 sum 数组表示序列 S 的前缀和,那么在每个回答中:(1)、S[l~r] 有偶数个 1,等价于 sum[l - 1] 与 sum[r] 的奇偶性相同。(2)、S[l ~ r] 有奇数个 1,等价于 sum[l - 1] 与 sum[r] 的奇偶性不同。

传递关系:1、若 x1 与 x2 的奇偶性相同,x2 与 x3  的奇偶性相同,则 x1 与 x3 的奇偶性相同。

2、若 x1 与 x2 的奇偶性不同,x2 与 x3  的奇偶性相同,则 x1 与 x3 的奇偶性不同。

3、若 x1 与 x2 的奇偶性不同,x2 与 x3  的奇偶性不同,则 x1 与 x3 的奇偶性相同。

另外,序列长度N很大,但问题数M较少,可以用离散化方法将每个问题的两个整数 l - 1 和 r 缩小到等价的 1~2M 以内的范围。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 10000+7;
struct node{int l, r, ans;
} query[maxn];
int a[maxn], d[maxn], fa[maxn];
int n, m, t;
void read_discrete(){cin >> n >> m;for(int i = 1; i <= m; i++){char str[5];scanf("%d %d %s", &query[i].l, &query[i].r, str);query[i].ans = (str[0] == 'o' ? 1 : 0);a[++t] = query[i].l - 1;a[++t] = query[i].r;}sort(a+1, a+t+1);n = unique(a+1, a+t+1) - a - 1;
}
int get(int x) {if(x == fa[x]) return x;return fa[x] = get(fa[x]);
}
int main()
{read_discrete();for(int i = 1; i <= 2*n; i++) fa[i] = i;for(int i = 1; i <= m; i++) {int x = lower_bound(a+1, a+n+1, query[i].l - 1) - a;int y = lower_bound(a+1, a+n+1, query[i].r) - a;int x_odd = x, x_even = x + n;int y_odd = y, y_even = y + n;if(query[i].ans == 0){if(get(x_odd) == get(y_even)){cout << i - 1 << endl;return 0;}fa[get(x_odd)] = get(y_odd);fa[get(x_even)] = get(y_even);}else {if(get(x_odd) == get(y_odd)){cout << i - 1 << endl;return 0;}fa[get(x_odd)] = get(y_even);fa[get(x_even)] = get(y_odd);}}cout << m << endl;return 0;
}