当前位置: 代码迷 >> 综合 >> 杭电1087Super Jumping(dp)
  详细解决方案

杭电1087Super Jumping(dp)

热度:88   发布时间:2023-11-24 22:51:58.0

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

思路

当做到n时,要把到n之间的所有点的最佳情况列出
如:
以第一个例子为例
第一个数1
当前第一个位置最大的和就是1
第二个数3
3>1
当前第二个位置最大的和就是3+1=4
第三个数
2>1
当前第三个位置最大的和就是2+1=3
2<3不做处理
由此可知
最大的和就是当前第二个位置就是4

代码示例

#include<iostream>
#include<cstdio>
#include<cmath>
#include<string>
#include<algorithm>
#include<set>
#include<iomanip>
typedef long long l;
using namespace std;
int main()
{
    int n; while (cin >> n){
    if (n == 0)break;int a[1005] = {
     0 };//具体数字int b[1005] = {
     0 };//目前为止路过自己这里的最大值int maxans = 0;for (int i = 1; i <= n; i++){
    int t; cin >> t;a[i] = t;b[i] = t;int maxn = 0;for (int j = 1; j < i; j++){
    if (t > a[j])maxn = max(maxn, b[j] + t);}b[i] = max(maxn,b[i]);if (b[i] > maxans)maxans = b[i];}cout << maxans << endl;}return 0;
}
  相关解决方案