当前位置: 代码迷 >> 综合 >> HDU 1598 find the most comfortable road
  详细解决方案

HDU 1598 find the most comfortable road

热度:99   发布时间:2023-11-24 22:37:58.0

find the most comfortable road

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8072    Accepted Submission(s): 3394


Problem Description
XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超级空中漫游结构)进行交流,每条SARS都对行驶在上面的Flycar限制了固定的Speed,同时XX星人对 Flycar的“舒适度”有特殊要求,即乘坐过程中最高速度与最低速度的差越小乘坐越舒服 ,(理解为SARS的限速要求,flycar必须瞬间提速/降速,痛苦呀 ),
但XX星人对时间却没那么多要求。要你找出一条城市间的最舒适的路径。(SARS是双向的)。

Input
输入包括多个测试实例,每个实例包括:
第一行有2个正整数n (1<n<=200)和m (m<=1000),表示有N个城市和M条SARS。
接下来的行是三个正整数StartCity,EndCity,speed,表示从表面上看StartCity到EndCity,限速为speedSARS。speed<=1000000
然后是一个正整数Q(Q<11),表示寻路的个数。
接下来Q行每行有2个正整数Start,End, 表示寻路的起终点。

Output
每个寻路要求打印一行,仅输出一个非负整数表示最佳路线的舒适度最高速与最低速的差。如果起点和终点不能到达,那么输出-1。

Sample Input
   
4 4 1 2 2 2 3 4 1 4 1 3 4 2 2 1 3 1 2

Sample Output
   
1 0

Author
ailyanlu

Source
HDU 2007-Spring Programming Contest - Warm Up (1)

Recommend
8600   |   We have carefully selected several similar problems for you:  1596 1142 1385 1690 2722 
kruskal + 并查集
按边长从小到大排序,然后从小到枚举边长,以该边作为最小值,再将比它大的边逐渐合并如果start与end的根节点相同说明联通,该边产生的最小差就是lenj - leni;
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
using namespace std;
#define INF 0x3f3f3f3f
#define N 1100
struct node {int u,v;int w;
}edge[N*5];
int father[N];int n, m;
bool cmp1(node a, node b)
{return a.w < b.w;
}
int findfather(int x)
{int a = x;while(x != father[x])x = father[x];while(a != father[a]) {int t = a;a = father[a];father[t] = x;}return x;
}void init()
{for(int i = 0; i <= n; i++)father[i] = i;return ;
}
int main()
{while(scanf("%d%d", &n, &m) != EOF) {for(int i = 0; i < m; i++)scanf("%d%d%d", &edge[i].u, &edge[i].v, &edge[i].w);sort(edge, edge + m, cmp1); //边长从小到大排序int Start, End ,q;int ans = INF;scanf("%d", &q);for(int k = 0; k < q; k++) {scanf("%d%d", &Start, &End);ans = INF;for(int i = 0; i < m; i++) {init();for(int j = i; j < m; j++) {int faA = findfather(edge[j].u);int faB = findfather(edge[j].v);father[faB] = faA;if(findfather(Start) == findfather(End)) {  //说明已经联通ans = min(ans, edge[j].w - edge[i].w);  //因为边长从小到大排序break;}}}if(ans == INF)printf("-1\n");elseprintf("%d\n", ans);}}return 0;
}


  相关解决方案