当前位置: 代码迷 >> C语言 >> 题目的意思我已经翻译了 再十一楼 请指教
  详细解决方案

题目的意思我已经翻译了 再十一楼 请指教

热度:118   发布时间:2007-10-29 14:17:59.0
题目的意思我已经翻译了 再十一楼 请指教

Time Limit:1000MS Memory Limit:65536K
Total Submit:2 Accepted:0

Description

Alice and Bob need to send secret messages to each other and are discussing ways to encode their messages:
Alice: “Let’s just use a very simple code: We’ll assign ‘A’ the code word 1, ‘B’ will be 2, and so on down to ‘Z’ being assigned 26.”
Bob: “That’s a stupid code, Alice. Suppose I send you the word ‘BEAN’ encoded as 25114. You could decode that in many different ways!”
Alice: “Sure you could, but what words would you get? Other than ‘BEAN’, you’d get ‘BEAAD’, ‘YAAD’, ‘YAN’, ‘YKD’ and ‘BEKD’. I think you would be able to figure out the correct decoding. And why would you send me the word ‘BEAN’ anyway?”
Bob: “OK, maybe that’s a bad example, but I bet you that if you got a string of length 500 there would be tons of different decodings and with that many you would find at least two different ones that would make sense.”
Alice: “How many different decodings?”
Bob: “Jillions!”
For some reason, Alice is still unconvinced by Bob’s argument, so she requires a program that will determine how many decodings there can be for a given string using her code.


Input

Input will consist of multiple input sets. Each set will consist of a single line of digits representing a
valid encryption (for example, no line will begin with a 0). There will be no spaces between the digits.
An input line of ‘0’ will terminate the input and should not be processed


Output

For each input set, output the number of possible decodings for the input string. All answers will be
within the range of a long variable.


Sample Input


25114
1111111111
3333333333
0


Sample Output


6
89
1


Source

[此贴子已经被作者于2007-11-2 13:55:32编辑过]

搜索更多相关的解决方案: 翻译  指教  

----------------解决方案--------------------------------------------------------
学校昨天的acm题目
报告给大家

[此贴子已经被作者于2007-11-2 13:01:35编辑过]


----------------解决方案--------------------------------------------------------
多谢大家的帮忙啊 对于我的问题 你们总是
能给我不同的思路 给我灵感 谢了

[此贴子已经被作者于2007-11-2 13:02:28编辑过]


----------------解决方案--------------------------------------------------------

好帖

[此贴子已经被作者于2007-10-31 20:55:51编辑过]


----------------解决方案--------------------------------------------------------

递归超时了

给个非递归的

#include <stdio.h>
#include <string.h>

#define N 48

void fibonacci(unsigned long *f)
{
int i;
f[0] = f[1] = 1;

for (i = 2; i < N; i++)
f[i] = f[i - 1] + f[i - 2];
}


int main()
{
unsigned long f[N];
int i;
char s[1000], last;
fibonacci(f);
while (EOF != scanf("%s", s) && *s != '0')
{
unsigned long count = 1;
unsigned long n = 0;

for (i = 0; i < strlen(s); i++)
if (s[i] <= '2')
break;
for(; i < strlen(s); i++)
{
if (s[i] <= '2')
{
n++;
last = s[i];
}
else if (n != 0)
{
if (last == '1' || s[i] <= '6')
count = count * (f[n] + f[n-1]);
else
count = count * f[n];
n = 0;
}
if (i == strlen(s) - 1 && n != 0)
count = count * f[n];
}
printf("%lu\n", count);
}

return 0;
}


----------------解决方案--------------------------------------------------------
不行啊
----------------解决方案--------------------------------------------------------

不行吗?是不是s[1000]长度不够啊?

把测试网址贴出来啊.


----------------解决方案--------------------------------------------------------

超时啊


----------------解决方案--------------------------------------------------------
http://210.31.185.229/JudgeOnline/showproblem?problem_id=1237
----------------解决方案--------------------------------------------------------

看不懂!不知道能不能啃动!顶一下!


----------------解决方案--------------------------------------------------------
  相关解决方案