题目链接
Description
You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.
Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.
Output
You need to answer all Q commands in order. One answer in a line.
Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.
Source
POJ Monthly–2007.11.25, Yang Yi
题意: 输入 n, m表示初始有 n 个数, 接下来 m 行输入, Q x y 表示询问区间 [x, y]的和;
C x y z 表示区间 [x, y] 内所有数加上 z ;
思路: 线段树区间更新&区间求和模板
#include<iostream>
#include<cstdio>
#include<stack>
using namespace std;
typedef long long ll;
const int N = 100005;
ll n,q,d,e,f,a[N],sum[N << 2],lazy[N << 2];
char c;
void build(ll k,ll l,ll r){
if(l == r){
sum[k] = a[l];return;}int mid = l + r >> 1;build(k << 1,l,mid);build(k << 1 | 1,mid + 1,r);sum[k] = sum[k << 1] + sum[k << 1 | 1];return;
}
void pushdown(ll k,ll len){
if(lazy[k]){
lazy[k << 1] += lazy[k];sum[k << 1] += lazy[k] * (len - (len >> 1));lazy[k << 1 | 1] += lazy[k];sum[k << 1 | 1] += lazy[k] * (len >> 1);lazy[k] = 0;}
}
ll query(ll k,ll l,ll r,ll L,ll R){
if(l > R || r < L) return 0;if(L <= l && R >= r) return sum[k];int mid = l + r >> 1;pushdown(k,r - l + 1);return query(k << 1,l,mid,L,R) + query(k << 1 | 1,mid + 1,r,L,R);
}
void update(ll k,ll l,ll r,ll L,ll R,ll val){
if(l > R || r < L) return;if(L <= l && R >= r){
sum[k] += val * (r - l + 1);lazy[k] += val; // +=return;}int mid = l + r >> 1;pushdown(k,r - l + 1);update(k << 1,l,mid,L,R,val);update(k << 1 | 1,mid + 1,r,L,R,val);sum[k] = sum[k << 1] + sum[k << 1 | 1];return;
}
int main(){
scanf("%lld%lld",&n,&q);for(int i = 1;i <= n;i++) scanf("%lld",a + i);build(1,1,n);while(q--){
scanf(" %c",&c);if(c == 'Q'){
scanf("%lld%lld",&d,&e);printf("%lld\n",query(1,1,n,d,e));}else{
scanf("%lld%lld%lld",&d,&e,&f);update(1,1,n,d,e,f);}}return 0;
}