Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 16050 | Accepted: 11288 |
Description
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn ? 1 + Fn ? 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:
0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is
.
Given an integer n, your goal is to compute the last 4 digits of Fn.
Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number ?1.
Output
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
Sample Input
0
9
999999999
1000000000
-1
Sample Output
0
34
626
6875
Hint
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by
.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:
.
Source
#include<cstdio>
#include<algorithm>
#include<string.h>
using namespace std;
struct M
{
int a[5][5];
void init()
{
a[1][1]=a[1][2]=a[2][1]=1;
a[2][2]=0;
}
}A;
M chengfa(M b,M c)
{
M ans;
for(int i=1;i<=2;i++)
{
for(int j=1;j<=2;j++)
{
ans.a[i][j]=0;
for(int k=1;k<=2;k++)
{
ans.a[i][j]+=b.a[i][k]*c.a[k][j];
}
ans.a[i][j]=ans.a[i][j]%10000;
}
}
return ans;
}
M pow(M a,int b)
{
M ans;
ans.a[1][1]=1;
ans.a[2][2]=1;
ans.a[1][2]=0;
ans.a[2][1]=0;
while(b)
{
if(b&1)
ans=chengfa(ans,a);
b>>=1;
a=chengfa(a,a);
}
return ans;
}
int main()
{
int n;
while(cin>>n,n!=-1)
{
M a;
a.init();
M b=pow(a,n);
cout<<b.a[1][2]<<endl;
}
return 0;
}