当前位置: 代码迷 >> 综合 >> Balanced Lineup 线段树 RMQ
  详细解决方案

Balanced Lineup 线段树 RMQ

热度:73   发布时间:2023-11-18 06:25:36.0
Balanced Lineup
Time Limit: 5000MS
Memory Limit: 65536K
Total Submissions: 56032
Accepted: 26268
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver


这题 求的是区间最值的差  所以用线段数和RMQ都可以 

线段树 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f
#define L i<<1,l,mid
#define R i<<1|1,mid+1,r
using namespace std;
int n;
int t[50000<<2],t2[50000<<2];
void creat(int i,int l,int r)
{
    if(l==r)
    {
        scanf("%d",&t[i]);
        t2[i]=t[i];
        return ;
    }
    int mid=(l+r)>>1;
    creat(L);
    creat(R);
    t[i]=min(t[i<<1],t[i<<1|1]);
    t2[i]=max(t2[i<<1],t2[i<<1|1]);
}
int cha(int i,int l,int r,int x,int y)//最小值 
{
    if(x<=l&&r<=y) return t[i];
    int mid=(l+r)>>1;
    int res=INF;
    if(x<=mid) res=min(cha(L,x,y),res);
    if(mid<y) res=min(cha(R,x,y),res);
    return res;
}
int cha1(int i,int l,int r,int x,int y)//最大值 
{
    if(x<=l&&r<=y) return t2[i];
    int mid=(l+r)>>1;
    int res=-1;
    if(x<=mid) res=max(cha1(L,x,y),res);
    if(mid<y) res=max(cha1(R,x,y),res);
    return res;
}
int main()
{
    int q;
    scanf("%d",&n);
    scanf("%d",&q);
    creat(1,1,n);
    while(q--)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        printf("%d\n",cha1(1,1,n,a,b)-cha(1,1,n,a,b));
    }
    return 0;
}

RMQ
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<math.h>
using namespace std;
int n;
int dp[50010][100];
int dq[50010][100];
void rmq()
{
    for(int j=1;(1<<j)<=n+1; j++)
    {
        for(int i=1;i+(1<<j)-1<=n;i++)
        {
            dp[i][j]=min(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
            dq[i][j]=max(dq[i][j-1],dq[i+(1<<(j-1))][j-1]);
        }
    }
}
int rmq1(int l,int r)//最小值 
{
    int k=(int)(log(r-l+1+0.0)/log(2.0));  
    return min(dp[l][k],dp[r-(1<<k)+1][k]);
}
int rmq2(int l,int r)//最大值 
{
    int k=(int)(log(r-l+1+0.0)/log(2.0));  
    return max(dq[l][k],dq[r-(1<<k)+1][k]);
}
int main()
{
int q;
    while(~scanf("%d%d",&n,&q))
    {
    for(int j=1; j<=n; j++)
    {
            scanf("%d",&dp[j][0]);
            dq[j][0]=dp[j][0];
    }
    rmq();
    while(q--)
    {
           int a,b;
           scanf("%d%d",&a,&b);
           printf("%d\n",rmq2(a,b)-rmq1(a,b));
    }
    }
    
    return 0;
}

人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想。