迷宫城堡
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 20170 Accepted Submission(s): 8810
Problem Description
为了训练小希的方向感,Gardon建立了一座大城堡,里面有N个房间(N<=10000)和M条通道(M<=100000),每个通道都是单向的,就是说若称某通道连通了A房间和B房间,只说明可以通过这个通道由A房间到达B房间,但并不说明通过它可以由B房间到达A房间。Gardon需要请你写个程序确认一下是否任意两个房间都是相互连通的,即:对于任意的i和j,至少存在一条路径可以从房间i到房间j,也存在一条路径可以从房间j到房间i。
Input
输入包含多组数据,输入的第一行有两个数:N和M,接下来的M行每行有两个数a和b,表示了一条通道可以从A房间来到B房间。文件最后以两个0结束。
Output
对于输入的每组数据,如果任意两个房间都是相互连接的,输出"Yes",否则输出"No"。
Sample Input
3 3 1 2 2 3 3 1 3 3 1 2 2 3 3 2 0 0
Sample Output
Yes No
Author
Gardon
Source
HDU 2006-4 Programming Contest
Recommend
lxj | We have carefully selected several similar problems for you: 1217 1162 1102 1068 1150
#include<iostream>
#include<cstdio>
#include<string>
#include<string.h>
#include<algorithm>
#include<vector>
#define maxn 10005
using namespace std;
int n,m;
int x,y;
int seq[maxn];
/*
在存储边的关系上,
采用vector来存储,下标访问,
动态数组的形式即可保证内存。。。对每个点进行DFS,
只要有一个点不满足要求,
则是No
*/
//bitset<maxn> mp[maxn];
vector<int> mp[maxn];
bool vis[maxn];
void dfs(int t)
{vis[t]=true;for(int i=0;i<mp[t].size();i++){if(vis[mp[t][i]]) continue;dfs(mp[t][i]);}
}
bool judge()
{for(int i=0;i<n;i++){memset(vis,0,sizeof(vis));dfs(i);for(int i=0;i<n;i++){if(vis[i]==false)return false;}}return true;
}
int main()
{while(cin>>n>>m&&(n||m)){memset(mp,0,sizeof(mp));for(int i=0;i<m;i++){cin>>x>>y;mp[x-1].push_back(y-1);}if(judge())cout<<"Yes"<<endl;elsecout<<"No"<<endl;}return 0;
}