“Well, it seems the first problem is too easy. I will let you know how foolish you are later.” feng5166 says.
“The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+…+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that “4 = 3 + 1” and “4 = 1 + 3” is the same in this problem. Now, you do it!”
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
今天看书学习了母函数,感觉挺好使的 。 虽然有的时候可以转化为DP,并且也没有DP的时间复杂度少,但是它简单啊,容易理解。
代码
#include<cstdio>
#define LL long long
const int N = 121+11;//假如题目只问到100为止
const int MAX = 121+11;//题目只有1,2,3这3种邮票
LL c1[N], c2[N];//c2是临时合并的多项式,c1是最终合并的多项式
int n;
void init(){c1[0] = 1;//一开始0的情况算一种 for(int i = 1; i <= MAX; i ++){
//把1分到MAXN的邮票合并,变成一个多项式 for(int j = 0; j < N; j += i){
//i分的邮票,步长是ifor(int k = 0; j + k < N; k ++){
//从x^0到x^N遍历一遍 c2[j + k] += c1[k];//因为j的所有项系数为1,所以c1[k]可以看成c1[k]*1; }} for(int j = 0; j < N; j ++){
//把c2的数据抄到c1,清空c2 c1[j] = c2[j];c2[j] = 0;}}
}
int main(){init();while(scanf("%d", &n) != EOF){printf("%lld\n", c1[n]);}
}