省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。
当N为0时输入结束。
Output
每个测试用例的输出占一行,输出全省畅通需要的最低成本。
Sample Input
3
1 2 1 0
1 3 2 0
2 3 4 0
3
1 2 1 0
1 3 2 0
2 3 4 1
3
1 2 1 0
1 3 2 1
2 3 4 1
0
Sample Output
3
1
0
SOLUTION: MST-KRUSKAL
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;#define N 10010int fat[N];
struct Node{int a, b, pri, chk;
};
int n, m;Node aa[N];int getf( int x){return (fat[x] == x) ? x : fat[x] = getf(fat[x]);
}void unite( int x, int y ){fat[ getf(x) ] = getf( y );
}int cmp( Node x, Node y ){if(x.chk != y.chk)return x.chk > y.chk;return x.pri < y.pri;
}int Kruskal(){int nE = 0, res = 0;sort( aa+1, aa+1+m, cmp);for ( int i = 1; i <= m; i++){if ( getf(aa[i].a) != getf( aa[i].b) ){unite( aa[i].a, aa[i].b );if ( aa[i].chk == 0 )res += aa[i].pri;nE++;}if ( nE == n-1 ) return res;}return 0;
}int main(){while (~scanf( "%d", &n ) && n ){m = n*(n-1)/2;for ( int i = 1; i <= m; i++){int a, b, c, d;scanf( "%d%d%d%d", &a, &b, &c, &d);aa[i].a = a, aa[i].b = b, aa[i].pri = c, aa[i].chk = d;}for ( int i = 1; i <= n; i++)fat[i] = i;printf( "%d\n", Kruskal());}
}