Description
您需要写一种数据结构(可参考题目标题),来维护一些数,其中需要提供以下操作:
1. 插入x数
2. 删除x数(若有多个相同的数,因只删除一个)
3. 查询x数的排名(若有多个相同的数,因输出最小的排名)
4. 查询排名为x的数
5. 求x的前驱(前驱定义为小于x,且最大的数)
6. 求x的后继(后继定义为大于x,且最小的数)
Input
第一行为n,表示操作的个数,下面n行每行有两个数opt和x,opt表示操作的序号(1<=opt<=6)
Output
对于操作3,4,5,6每行输出一个数,表示对应答案
Sample Input
10
1 106465
4 1
1 317721
1 460929
1 644985
1 84185
1 89851
6 81968
1 492737
5 493598
Sample Output
106465
84185
492737
HINT
1.n的数据范围:n<=100000
2.每个数的数据范围:[-2e9,2e9]
solution:Treap
/**************************************************************Problem: 3224User: VenishelLanguage: C++Result: AcceptedTime:388 msMemory:3636 kb
****************************************************************/#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int N=1e5+7;
inline int rnd(){static int seed=914;return seed=int(seed*48271LL%2147483647);
}
struct Node{int ls, rs, sz, r, v, w;
}tr[N];
int cnt, ans, root;
void pushup( int nd ){tr[nd].sz=tr[tr[nd].ls].sz+tr[tr[nd].rs].sz+tr[nd].w;
}
void lrot( int &nd ){int t=tr[nd].rs;tr[nd].rs=tr[t].ls; tr[t].ls=nd;tr[t].sz=tr[nd].sz; pushup(nd); nd=t;
}
void rrot( int &nd ){int t=tr[nd].ls;tr[nd].ls=tr[t].rs; tr[t].rs=nd;tr[t].sz=tr[nd].sz; pushup(nd); nd=t;
}
void insert( int &nd, int val ){if(nd==0) { nd=++cnt; tr[nd].v=val; tr[nd].r=rnd(); tr[nd].w=tr[nd].sz=1; return ; }tr[nd].sz++;if( tr[nd].v==val ){ tr[nd].w++; return ; }else if( tr[nd].v>val ) { insert(tr[nd].ls,val); if( tr[tr[nd].ls].r>tr[nd].r ) rrot(nd); }else { insert( tr[nd].rs, val ); if( tr[tr[nd].rs].r>tr[nd].r ) lrot(nd); }
}
void remove( int &nd, int val ){if(nd==0) return;if(tr[nd].v==val){if(tr[nd].w>1) { tr[nd].sz--, tr[nd].w--; return ; }if( tr[nd].ls*tr[nd].rs==0 ) nd=tr[nd].ls+tr[nd].rs;else {if( tr[tr[nd].ls].r>tr[tr[nd].rs].r ) rrot(nd), remove(nd,val);else lrot(nd), remove(nd,val);}} else if(tr[nd].v>val ) tr[nd].sz--, remove(tr[nd].ls,val);else tr[nd].sz--, remove(tr[nd].rs,val);
}
void query_pre( int nd, int val ){if( nd==0 ) return;if( val>tr[nd].v ){ans=tr[nd].v; query_pre(tr[nd].rs,val);} else query_pre(tr[nd].ls,val);
}
void query_sub( int nd, int val ){if( nd==0 ) return;if( val<tr[nd].v ){ans=tr[nd].v; query_sub(tr[nd].ls,val);} else query_sub(tr[nd].rs, val);
}
int query_rank( int nd, int val ){if( nd==0 ) return 0;if( val==tr[nd].v ) return tr[tr[nd].ls].sz+1;else if( val<tr[nd].v ) return query_rank( tr[nd].ls, val );else return tr[tr[nd].ls].sz+tr[nd].w+query_rank( tr[nd].rs, val);
}
int query_num( int nd, int k ){if( nd==0 ) return 0;if( k<=tr[tr[nd].ls].sz ) return query_num( tr[nd].ls, k );else if( k>tr[tr[nd].ls].sz+tr[nd].w ) return query_num( tr[nd].rs, k-tr[tr[nd].ls].sz-tr[nd].w);else return tr[nd].v;
}
int main(){int n;scanf("%d", &n );cnt=0; root=0;for ( int i=1; i<=n; i++ ){int opt, x;scanf("%d%d", &opt, &x );switch(opt){case 1:insert(root,x);break;case 2:remove(root,x);break;case 3:printf("%d\n",query_rank(root,x) );break;case 4:printf("%d\n",query_num(root,x) );break;case 5:ans=0;query_pre(root,x);printf("%d\n",ans);break;case 6:ans=0;query_sub(root,x);printf("%d\n",ans);break;}}
}