原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=2680
Problem Description One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
Input There are several test cases.
Output The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”. Sample Input 5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1 Sample Output 1 -1 |
同样的dijsktra;我的博文有好几种对于其不同形式的解法,可以去看看。
此题有个坑点:不是无向边,
这个题属于:多源起点,一个终点!
老套路的模板!
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int Div[1002];
int vis[1002];
int a[1002][1002];
int INF=30000;
void dijsktra(int n){int i,j;for(i=0;i<=n;i++){Div[i]=a[0][i];vis[i]=0;}vis[0]=1;//Div[v0]=0;int minpox=0;for(i=0;i<=n;i++){int minINF=INF;for(j=0;j<=n;j++){if(!vis[j]&&Div[j]<minINF){minINF=Div[j];minpox=j;}}vis[minpox]=1;for(j=0;j<=n;j++){if(!vis[j]&&Div[j]>Div[minpox]+a[minpox][j])Div[j]=Div[minpox]+a[minpox][j];}}
}
int main(){int n,m,s,i,j,p,q,t,w,v0,book[1002],k;while(scanf("%d%d%d",&n,&m,&s)!=EOF){k=0;for(i=0;i<=n;i++){for(j=0;j<=n;j++){a[i][j]=INF;if(i==j)a[i][j]=0;}}for(i=0;i<m;i++){scanf("%d %d %d",&p,&q,&t);if(a[p][q]>t)a[p][q]=t;}scanf("%d",&w);for(i=0;i<w;i++){scanf("%d",&v0);a[0][v0]=0;} dijsktra(n);if(Div[s]!=INF)printf("%d\n",Div[s]);elseprintf("-1\n");}return 0;
}