1072 Gas Station (30分)
题目链接
A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.
Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.
- Input Specification:
Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤10
?3
?? ), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤10
?4
?? ), the number of roads connecting the houses and the gas stations; and D
?S
?? , the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.
Then K lines follow, each describes a road in the format
P1 P2 Dist
where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.
-
Output Specification:
For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution. -
Sample Input 1:
4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2
- Sample Output 1:
G1
2.0 3.3
- Sample Input 2:
2 1 2 10
1 G1 9
2 G1 20
- Sample Output 2:
No Solution
- 自作答案
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<string.h>
using namespace std;const int MAXV = 1020;
const int INF = 1000000000;int N,M,K,Ds;
int G[MAXV][MAXV];
bool vis[MAXV] = {
false};
int d[MAXV];int getId(char str[])
{
int len = strlen(str);int i = 0;int sum = 0;i = 0;//**************while(i<len){
if(str[i] != 'G'){
sum = sum*10+(str[i]-'0');}i++;}if(str[0] == 'G') return sum + N;else return sum;
}void Dijkstra(int s)
{
//fill(vis,vis + MAXV,false);memset(vis,false,sizeof(vis));//**************fill(d,d + MAXV,INF);d[s] = 0;for(int i = 0;i<N + M;i++){
int u = -1,MIN = INF;for(int j = 1;j<=N+M;j++){
if(vis[j] == false && d[j] < MIN){
u = j;MIN = d[j];}}if(u == -1) return;vis[u] = true;//**************for(int v = 1;v <= N + M;v++){
if(vis[v] == false && G[u][v] != INF){
if(d[v] > G[u][v] + d[u]){
d[v] = d[u] + G[u][v];}}}}
}int main()
{
int i,j;scanf("%d%d%d%d",&N,&M,&K,&Ds);fill(G[0],G[0] + MAXV*MAXV,INF);//**************for(i = 0;i<K;i++){
char str1[10],str2[10];int u,v;int w;scanf("%s%s%d",str1,str2,&w);u = getId(str1);v = getId(str2);//printf("%d %d\n",u,v);G[u][v] = G[v][u] = w;}/*for(i = 1;i<=N+M;i++){
for(j = 1;j<=N+M;j++)printf("%d ",G[i][j]);printf("\n");}*/int ansId = -1;//赋初值的原因是 判断有没有解double ansDis = -1;//最终的结果是求 最大的最短距离 为了更新,要赋初值为很小的数字,此处为-1double ansAvg = INF;//最终的结果是求 最小的平均距离for(i = N +1;i <= N + M;i++){
Dijkstra(i);double dis = INF;double avg = 0;for(j = 1;j<=N;j++){
if(d[j] > Ds){
dis = -1;break;}if(d[j] < dis) dis = d[j];avg +=1.0*d[j]/N;}if(dis == -1) continue;else{
if(dis>ansDis){
ansId = i;ansDis = dis;ansAvg = avg;}else if(dis == ansDis && avg<ansAvg){
ansId = i;ansAvg = avg;}}}if(ansId == -1) printf("No Solution\n");else{
printf("G%d\n",ansId - N);printf("%.1f %.1f\n",ansDis,ansAvg);}return 0;
}