题解目录
-
- 1002 A+B for Polynomials (25分)
- Input Specification:
- Output Specification:
- Sample Input:
- Sample Output:
- submit:
1002 A+B for Polynomials (25分)
This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 a?N1 N2 aN2… NK aN?K where K is the number of nonzero terms in the polynomial, N?i?and aNi (i=1,2,?,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N K<?<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
submit:
#include<iostream>
#include<cstring>using namespace std;
const int MAX_N = 1000+5;
float A[MAX_N];int main(){
memset(A, 0, sizeof(A)); for(int i = 0; i < 2; i++){
int k;scanf("%d", &k);for(int j = 0; j < k; j++){
int exponents;float coefiiceints;cin>>exponents>>coefiiceints;A[exponents] += coefiiceints;}}int sum=0;for(int i = 0; i < MAX_N; i++) if(A[i]) sum++;cout<<sum;for(int i = MAX_N; i >= 0; i--){
if(A[i]) printf(" %d %.1f",i, A[i]); } return 0;
}