A fat mouse prepared M pounds of cat food,ready to trade with the cats guarding the warehouse containing his
favorite food:peanut. The warehouse has N rooms.The ith room containsW[i] pounds of peanut and requires
F[i] pounds of cat food. Fatmouse does not have to trade for all the peanut in the room,instead,he may get
W[i]*a% pounds of peanut if he pays F[i]*a% pounds of cat food.The mouse is a stupid mouse,so can you tell
him the maximum amount of peanut he can obtain.
-
输入
- The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers W[i] and F[i] respectively. The test case is terminated by two -1. All integers are not greater than 1000. 输出
- For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of penaut that FatMouse can obtain. 样例输入
-
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
样例输出
-
13.333 31.500
题目的意思是:猫粮换花生。有n个仓库,每个仓库有w的花生,需要用f的猫粮交换。可以按照比例换,问m的猫粮最多能换多少花生。
思路:用猫粮换花生。猫粮是背包容量,w是价值,f是重量,物品可以分割。那么就是尽可能放单位重量价值最大的物品。按照w/f进行排序,从单位价值最大开始装,直到背包装满或者物品装完。
#include<cstdio>
#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
struct Room{double w,f;
}r[10000];
bool cmp(Room r1,Room r2){return (r1.w/r1.f)>(r2.w/r2.f);
}
int m,n;
int main(){while(scanf("%d%d",&m,&n)!=EOF&&(m!=-1&&n!=-1)){for(int i=0 ;i<n ;i++){scanf("%lf%lf",&r[i].w,&r[i].f);}sort(r,r+n,cmp);double ans = 0;int i=0;while(m&&i<n){//背包装完或者物品装完 if(r[i].f<=m){ans += r[i].w;m-=r[i].f;}else{ans += m*(r[i].w/r[i].f);m = 0;}i++;}printf("%.3lf\n",ans);}return 0;
}