点击链接PAT乙级-AC全解汇总
题目:
本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [?1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出 ERROR: X is not a legal number
,其中 X
是输入。最后在一行中输出结果:The average of K numbers is Y
,其中 K
是合法输入的个数,Y
是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined
替换 Y
。如果 K
为 1,则输出 The average of 1 number is Y
。
输入样例 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例 2:
2
aaa -9999
输出样例 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
我的代码:
#include<iostream>
#include<cstdio>
#include<vector>
#include<string>
#include<set>
#include<map>
#include<algorithm>
#include<cmath>
#include<ctime>
#include<cstring>
#include<sstream>
using namespace std;
//有的时候题目是一起做的,所以会有不需要的头文件int main()
{
int N;cin>>N;int K=0;double sum=0;for(int i=0;i<N;i++){
string str_input;cin>>str_input;string str(str_input);double num=0;bool flag_isnum=true;bool flag_minus=false;bool flag_first=true;int flag_point=0;while(str.length()>0){
if((str[0]>='0'&&str[0]<='9')||str[0]=='.'||str[0]=='-'||flag_isnum){
if(flag_point>0)flag_point++;//记录小数点的位置if(str[0]=='.'){
if(flag_point!=0)flag_isnum=false;else flag_point++;}else if(str[0]=='-'){
if(flag_first)flag_minus=true;else flag_isnum=false;}else{
num=num*10+str[0]-'0';}}elseflag_isnum=false;str.erase(0,1);flag_first=false;}if(flag_point)flag_point--;num=num*pow(0.1,flag_point);if(flag_isnum&&flag_point<=2&&num>=-1000&&num<=1000){
if(flag_minus)sum-=num;else sum+=num;K++;}elsecout<<"ERROR: "<<str_input<<" is not a legal number"<<endl;}cout<<"The average of "<<K;if(K==1)cout<<" number is ";else cout<<" numbers is ";if(K==0)cout<<"Undefined"<<endl;else printf("%.2f",sum/K);return 0;
}
注意几个特殊情况:
-只可能出现在第一位
0-5
0-.5
- -0.5
一开始我还觉得区分-00.5 和 -0.05 和 -100.05 最难,后来发现是我想多了