当前位置: 代码迷 >> 综合 >> PAT乙级-1093 字符串A+B (20分)
  详细解决方案

PAT乙级-1093 字符串A+B (20分)

热度:90   发布时间:2023-09-27 00:13:45.0

点击链接PAT乙级-AC全解汇总

题目:
给定两个字符串 A 和 B,本题要求你输出 A+B,即两个字符串的并集。要求先输出 A,再输出 B,但重复的字符必须被剔除

输入格式:
输入在两行中分别给出 A 和 B,均为长度不超过 10?6?? 的、由可见 ASCII 字符 (即码值为32~126)和空格组成的、由回车标识结束的非空字符串。

输出格式:
在一行中输出题面要求的 A 和 B 的和。

输入样例:

This is a sample test
to show you_How it works

输出样例:

This ampletowyu_Hrk

我的代码:

#include<bits/stdc++.h>
using namespace std;int main()
{
    string str1,str2,res;getline(cin,str1);getline(cin,str2);int have[200]={
    0};for(int i=0;i<str1.length();i++){
    if(have[str1[i]]==0){
    res+=str1[i];have[str1[i]]=1;}}for(int i=0;i<str2.length();i++){
    if(have[str2[i]]==0){
    res+=str2[i];have[str2[i]]=1;}}cout<<res<<endl;return 0;
}