点击链接PAT甲级-AC全解汇总
题目:
Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.
Input Specification:
Each input file contains one test case which gives a non-empty string of length no more than 1000.
Output Specification:
For each test case, simply print the maximum length in a line.
Sample Input:
Is PAT&TAP symmetric?
Sample Output:
11
题意:
找字符串最长回文子串的长度
我的思路:
找到某个可能成为回文的中心的点,计算从他出发,两边多少长度都是一样的。
注意: 回文的中心可能是一个点,也可能是两个点
我的代码:
#include<bits/stdc++.h>
using namespace std;
string str;
int fun(int left,int right,int len){
if(str[left]!=str[right]||left<0||right>=str.length())return len;return fun(left-1,right+1,len+2);
}
int main()
{
getline(cin,str);int max_len=1;for(int i=0;i<str.length();i++){
if(str[i]==str[i+1])max_len=max(max_len,fun(i,i+1,0));if(str[i]==str[i+2])max_len=max(max_len,fun(i,i+2,1));}cout<<max_len<<endl;return 0;
}