1058. 选择题(20)
时间限制
300 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue
批改多选题是比较麻烦的事情,本题就请你写个程序帮助老师批改多选题,并且指出哪道题错的人最多。
输入格式:
输入在第一行给出两个正整数N(<=1000)和M(<=100),分别是学生人数和多选题的个数。随后M行,每行顺次给出一道题的满分值(不超过5的正整数)、选项个数(不少于2且不超过5的正整数)、正确选项个数(不超过选项个数的正整数)、所有正确选项。注意每题的选项从小写英文字母a开始顺次排列。各项间以1个空格分隔。最后N行,每行给出一个学生的答题情况,其每题答案格式为“(选中的选项个数 选项1 ……)”,按题目顺序给出。注意:题目保证学生的答题情况是合法的,即不存在选中的选项数超过实际选项数的情况。
输出格式:
按照输入的顺序给出每个学生的得分,每个分数占一行。注意判题时只有选择全部正确才能得到该题的分数。最后一行输出错得最多的题目的错误次数和编号(题目按照输入的顺序从1开始编号)。如果有并列,则按编号递增顺序输出。数字间用空格分隔,行首尾不得有多余空格。如果所有题目都没有人错,则在最后一行输出“Too simple”。
输入样例:3 4 3 4 2 a c 2 5 1 b 5 3 2 b c 1 5 4 a b d e (2 a c) (2 b d) (2 a c) (3 a b e) (2 a c) (1 b) (2 a b) (4 a b d e) (2 b d) (1 e) (2 b c) (4 a b c d)输出样例:
3 6 5 2 2 3 4
#include <cstdio>
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;struct timu{int score;int num_xx;int num_rt;char zq[5];
}ti[105];struct huizong{int tihao;int renshu;bool operator<(const struct huizong b)const{if(renshu!=b.renshu){return renshu>b.renshu;}else{return tihao<b.tihao;} }
}huiz[105];int main(){int N,M;for(int i=0;i<105;i++){huiz[i].renshu=0;huiz[i].tihao=i;}scanf("%d%d",&N,&M);for(int i=0;i<M;i++){cin>>ti[i].score>>ti[i].num_xx>>ti[i].num_rt;for(int j=0;j<ti[i].num_rt;j++){cin>>ti[i].zq[j];}}
// cout<<"-----------"<<endl;
// for(int i=0;i<M;i++){
// cout<<ti[i].score<<" "<<ti[i].num_xx<<" "<<ti[i].num_rt<<" ";
//
// for(int j=0;j<ti[i].num_rt;j++){
// cout<<ti[i].zq[j]<<" ";
// }
// cout<<endl;
// }int defen,answer;char xues[5];string s;char temp;temp=getchar();//cout<<temp<<endl;for(int i=0;i<N;i++){defen=0; int k;getline(cin,s);int pos1=0,pos2=0;for(int j=0;j<M;j++){answer=1; pos1=s.find("(",pos2);// cout<<"pos1="<<pos1<<" ";k=s[pos1+1]-'0';pos2=s.find(")",pos1);// cout<<"pos2="<<pos2<<" ";// cout<<k<<" "<<endl;if(k!=ti[j].num_rt){huiz[j+1].renshu++; // cout<<"k="<<k<<" num_rt="<<ti[j].num_rt<<endl;continue;} pos1=pos1+3;for(int xxgs=0;xxgs<k;xxgs++){xues[xxgs]=s[pos1];pos1+=2;if(xues[xxgs]!=ti[j].zq[xxgs]){answer=0;huiz[j+1].renshu++;break;}}//cout<<"answer="<<answer<<endl;if(answer==1){defen+=ti[j].score;}}cout<<defen<<endl;}sort(huiz,huiz+M+1);if(huiz[0].renshu==0){printf("Too simple\n");}else{int max=huiz[0].renshu;printf("%d %d",huiz[0].renshu,huiz[0].tihao);for(int i=1;huiz[i].renshu==max;i++){printf(" %d",huiz[i].tihao);}}// for(int i=0;i<M;i++){
// printf("%d %d ",huiz[i].renshu,huiz[i].tihao);
// }return 0;
}
这道题最大的问题就是要求比较繁杂。需要捋清关系。
-----------------------------------------
我胡汉三又回来了。( ̄▽ ̄)"