题目描述
输入一系列整数,建立二叉排序数,并进行前序,中序,后序遍历。
输入
输入第一行包括一个整数n(1<=n<=100)。接下来的一行包括n个整数。
输出
可能有多组测试数据,对于每组数据,将题目所给数据建立一个二叉排序树,并对二叉排序树进行前序、中序和后序遍历。每种遍历结果输出一行。每行最后一个数据之后有一个空格。
样例输入
1 2 2 8 15 4 21 10 5 39
样例输出
2 2 2 8 15 8 15 15 8 21 10 5 39 5 10 21 39 5 10 39 21
#include<stdio.h>
int father[10000]={0};
struct node{int data;node* lChild;node* rChild;
};
node* Newnode(int x){node* root=new node;root->data=x;root->lChild=root->rChild=NULL;return root;
}
void insert(node* &root,int x)
{if(root==NULL){root=Newnode(x); //注意这里是root=Newnode(x);不是单独Newnode(x); return;}if(x==root->data)return;if(x>root->data)insert(root->rChild,x);else{insert(root->lChild,x);}
}
node* create(int data[],int n){int i;node* root=NULL;for(i=0;i<n;i++){insert(root,data[i]);}return root;
}
void preorder(node* root)
{if(root==NULL)return;printf("%d ",root->data);preorder(root->lChild);preorder(root->rChild);}
void inorder(node* root)
{if(root==NULL)return;inorder(root->lChild);printf("%d ",root->data);inorder(root->rChild);
}
void postorder(node* root)
{if(root==NULL)return;postorder(root->lChild);postorder(root->rChild);printf("%d ",root->data);
}
int main(){int n;int data[110];while(scanf("%d",&n)!=EOF&&n!=0){for(int i=0;i<n;i++){scanf("%d",&data[i]);}node *root=create(data,n);//printf("...........\n");//preorder(create(data,n));preorder(root);printf("\n");inorder(root);printf("\n");postorder(root);printf("\n");}return 0;
}