当前位置: 代码迷 >> 综合 >> java实现 HDU 2553 n皇后解的数量
  详细解决方案

java实现 HDU 2553 n皇后解的数量

热度:52   发布时间:2024-03-08 21:35:34.0

在N*N的方格棋盘放置了N个皇后,使得它们不相互攻击(即任意2个皇后不允许处在同一排,同一列,也不允许处在与棋盘边框成45角的斜线上。
你的任务是,对于给定的N,求出有多少种合法的放置方法。

Input
共有若干行,每行一个正整数N≤10,表示棋盘和皇后的数量;如果N=0,表示结束。

Output
共有若干行,每行一个正整数,表示对应输入行的皇后的不同放置数量。

Sample Input
1
8
5
0

Sample Output
1
92
10

代码

import java.util.Scanner;public class n皇后的解的数量 {
    private static final int MAXNUM = 15;private static int n = 0;private static int cnt = 0;private static int[][] chess = new int [MAXNUM][MAXNUM];private static int[] ans = new int [MAXNUM];public static void main(String[] args) {
    //存数组里,否则会超时for(n = 1; n <= 10; n++){
    cnt = 0;solve(0);ans[n] = cnt;}Scanner scan = new Scanner(System.in);while((n = scan.nextInt())!=0){
    	System.out.println(ans[n]);}scan.close();}public static void solve(int row) {
    if(row == n) {
    cnt++;return ;}for(int i = 0; i < n; i++) {
    if(valid(row, i)) {
    chess[row][i] = 1;solve(row + 1);chess[row][i] = 0;}}}private static boolean valid(int row, int col) {
    //上方是否有棋子for (int i = 0; i < row; i++) {
    if (chess[i][col] == 1) {
    return false;}}//右上是否有棋子for (int i = row - 1, j = col + 1; i >= 0 && j < n; i--, j++) {
    if (chess[i][j] == 1) {
    return false;}}//左上是否有棋子for (int i = row - 1, j = col - 1; i >= 0 && j >= 0; i--, j--) {
    if (chess[i][j] == 1) {
    return false;}}return true;}
}
  相关解决方案