1037: 四则运算
时间限制: 1 Sec 内存限制: 30 MB
提交: 61607 解决: 17662
[状态] [讨论版] [提交] [命题人:admin]
题目描述
给你一个简单的四则运算表达式,包含两个实数和一个运算符,请编程计算出结果
输入
表达式的格式为:s1 op s2, s1和s2是两个实数,op表示的是运算符(+,-,*,/),也可能是其他字符
输出
如果运算符合法,输出表达式的值;若运算符不合法或进行除法运算时除数是0,则输出"Wrong input!"。最后结果小数点后保留两位。
样例输入 Copy
1.0 + 1.0
样例输出 Copy
2.00
提示
除数是0,用|s2|<1e-10(即10的-10次方)判断
python:
(一):
x,n,y= input().split()
x,y= float(x),float(y)if n== '+':print('%.2f'%(x+y))
elif n== '-':print('{:.2f}'.format(x-y))
elif n== '*':print('{:.2f}'.format(x*y))
elif n== '/' and abs(y)>= 1e-10:print('%.2f'%(x/y))
else:print("Wrong input!")
(二):
s= input()
ls= s.split()if ls[1] in ['+', '-', '*', '/']:if ls[1]== '/' and abs(eval(ls[2]))< 1e-10:print('Wrong input!')else:print('{:.2f}'.format(eval(s)))
else:print('Wrong input!')