当前位置: 代码迷 >> 综合 >> PAT甲级真题 1108 Finding Average (20分) C++实现(stringstream判断string转float/double是否合法)
  详细解决方案

PAT甲级真题 1108 Finding Average (20分) C++实现(stringstream判断string转float/double是否合法)

热度:57   发布时间:2024-02-04 23:32:55.0

题目

he basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [?1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.
Output Specification:
For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.
Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

思路

使用stringstream实现字符串向double的转化,如果失败会返回false,这样就能判断是否为合法float,用法如下:

string str;
if (!getline(cin, str))
{// error: didn't get any input
}
istringstream ss(str);
float f;
if (!(ss >> f))
{// error: didn't convert to a float
}

如果是float,还需判断是否在范围-1000~1000内,以及小数点后是否仅有2位:

if (str.find('.')!=string::npos && str.size()-str.find('.')>3){flag = false;    }

注意不要忽略前面的str.find('.')!=string::npos

代码

#include <iostream>
#include <sstream>
#include <iomanip>
using namespace std;int main() {int n;cin >> n;double sum = 0;int legal = 0;string str;double temp;for (int i=0; i<n; i++){bool flag = false;cin >> str; stringstream ss(str);if (ss>>temp && temp>=-1000 && temp<=1000){ flag = true;if (str.find('.')!=string::npos && str.size()-str.find('.')>3){flag = false;    }}if (flag){legal++;sum += temp;}else{cout << "ERROR: " << str << " is not a legal number" << endl;}}if (legal==0){cout << "The average of 0 numbers is Undefined" << endl;}else if (legal==1){cout << "The average of 1 number is " << setprecision(2) << fixed << sum << endl;}else{cout << "The average of "<< legal << " numbers is " << setprecision(2) << fixed << sum / legal<< endl;}return 0;
}
  相关解决方案