程序员入门水平,贴出代码大家一起进步!
原题传送门
题目
This time, you are supposed to find A×B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
where K is the number of nonzero terms in the polynomial,
and
are the exponents and coefficients, respectively. It is given that
.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 3 3.6 2 6.0 1 1.6
思路||总结
- 设置20001初始值为0的列表,对于两个因子,将其系数的乘积加在列表位置为两个因子的幂的和的位置。
- count一下又多少个非零项,然乎输出。
AC代码
import numpy as npdef main():str_0 = input().strip().split()str_0[0] = int(str_0[0])for i in range(str_0[0]):str_0[i * 2 + 1] = int(str_0[i * 2 + 1])str_0[i * 2 + 2] = float(str_0[i * 2 + 2])str_1 = input().strip().split()str_1[0] = int(str_1[0])for i in range(str_1[0]):str_1[i * 2 + 1] = int(str_1[i * 2 + 1])str_1[i * 2 + 2] = float(str_1[i * 2 + 2])result = np.zeros(2001)count = 0for i in range(str_0[0]):for j in range(str_1[0]):# 对于两个因子,将其系数的乘积加在列表位置为两个因子的幂的和的位置result[str_0[i * 2 + 1] + str_1[j * 2 + 1]] += str_0[i * 2 + 2] * str_1[j * 2 + 2]# 数一下有多少个非0项for i in range(2001):if result[i] != 0:count += 1print(count, end='')for i in range(2001):if result[2000 - i] != 0:print(' %d %.1f' % (2000 - i, result[2000 - i]), end='')main()