当前位置: 代码迷 >> 综合 >> PAT-A-1053 Path of Equal Weight (30分)(dfs)
  详细解决方案

PAT-A-1053 Path of Equal Weight (30分)(dfs)

热度:50   发布时间:2024-01-28 12:00:42.0

Given a non-empty tree with root R, and with weight W
?i
?? assigned to each tree node T
?i
?? . The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.在这里插入在这里插入图片描述图片描述
Input Specification:

在这里插入图片描述

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:
For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note:sequence {A ?1 ?? ,A ?2 ?? ,?,A ?n ?? } is said to be greater than sequence {B ?1 ?? ,B ?2 ?? ,?,B ?m ?? } if there exists 1≤k<min{n,m} such that A ?i ?? =B ?i ?? for i=1,?,k, and A ?k+1 ?? >B ?k+1 ?? .

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
dfs方法代码如下:

#include <iostream>
#include <algorithm>
#include <vector>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <string.h>
#include <math.h>
using namespace std;
const int maxn=110;
struct node
{int weight;//结点重量vector<int> child;
}Node[maxn];
int n,m,W;//n为结点数,m为叶结点数,W为目标重量
int path[maxn];//记录路径
//index为结点编号,numNode为当前路径上的结点个数,sum当前的路径上结点权值之和
void DFS(int index,int numNode,int sum){if(sum>W){//当前和sum超过目标W,直接返回return;}if(sum==W){if(Node[index].child.size()!=0){return;//如果还没到叶子结点,直接返回}//到达叶子结点输出for(int i = 0 ; i < numNode ; i ++){printf("%d",Node[path[i]].weight);if(i<numNode-1){printf(" ");}else{printf("\n");}}return;}for(int i = 0 ; i < Node[index].child.size() ; i ++){int child=Node[index].child[i];//结点index的第i号子结点编号path[numNode]=child;//将结点child加到path末尾DFS(child,numNode+1,sum+Node[child].weight);}
}
bool cmp(int a,int b){return Node[a].weight>Node[b].weight;//按重量从大到小排序
}
int main(){scanf("%d%d%d",&n,&m,&W);for(int i = 0 ; i < n ; i ++){scanf("%d",&Node[i].weight);}int parent ,child, k;for(int i = 0 ; i < m ; i ++){scanf("%d%d",&parent,&k);for(int j = 0 ; j < k ; j ++){scanf("%d",&child);Node[parent].child.push_back(child);}sort(Node[parent].child.begin(),Node[parent].child.end(),cmp);//对该parent结点的孩子结点按重量由大到小排序}DFS(0,1,Node[0].weight);// system("pause");return 0;
}
  相关解决方案