当前位置: 代码迷 >> 综合 >> JAVA7-3 定义类 (5 分)
  详细解决方案

JAVA7-3 定义类 (5 分)

热度:36   发布时间:2024-01-21 03:34:01.0

7-3 定义类 (5 分)

请补充以下代码,完成输出要求。(注意:需要提交完整代码)

import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
    Scanner in = new Scanner(System.in);int a,b,c,d,e;a = in.nextInt();b = in.nextInt();c = in.nextInt();d = in.nextInt();e = in.nextInt();RR rr = new RR();double dd = rr.fun(a,b,c,d,e);System.out.printf("%.2f",dd);}
}
class RR{
    }

输入格式:

在一行中给出5个不超过1000的正整数。

输出格式:

输出5个整数的平均值,保留小数点后两位。

输入样例:

1 2 3 4 5

输出样例:

3.00

我的代码如下:

import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
    Scanner in = new Scanner(System.in);int a,b,c,d,e;a = in.nextInt();b = in.nextInt();c = in.nextInt();d = in.nextInt();e = in.nextInt();RR rr = new RR();double dd = rr.fun(a,b,c,d,e);System.out.printf("%.2f",dd);}
}
class RR
{
    double fun(int a,int b,int c,int d,int e){
    return (a+b+c+d+e)/5.0;}}