当前位置: 代码迷 >> 综合 >> zoj 3332 Strange Country II(DFS或者网上哈密尔顿图解决)
  详细解决方案

zoj 3332 Strange Country II(DFS或者网上哈密尔顿图解决)

热度:6   发布时间:2024-01-13 20:40:33.0

1、http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3757

2、题目大意:

给定一张图,求出从一个点出发,经过所有的点有且仅一次,输出路径,如果不存在这样的一条路径,输出“Impossible”;

3、题目:

Strange Country II

           


           

Time Limit: 1 Second                                    Memory Limit: 32768 KB                                                    Special Judge                           

           


           

You want to visit a strange country. There are n cities in the country. Cities are numbered from 1 to n. The unique way to travel in the country is taking planes.Strangely, in this strange country, for every two cities A and B, there is a flight from A to B or from B to A, but not both.You can start at any city and you can finish your visit in any city you want. You want to visit each city exactly once. Is it possible?

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 100) indicating the number of test cases.Then T test cases follow. Each test case starts with a line containing an integer n (0 < n <= 100), which is the number of cities.Each of the next n * (n - 1) / 2 lines contains 2 numbers A, B (0 < A, B <= n, A != B), meaning that there is a flight from city A to city B.

Output

For each test case:

  • If you can visit each city exactly once, output the possible visiting order in a single line please. Separate the city numbers by spaces. If there are more than one orders, you can output any one.
  • Otherwise, output "Impossible" (without quotes) in a single line.

Sample Input

3
1
2
1 2
3
1 2
1 3
2 3

Sample Output

1
1 2
1 2 3

 

4、AC代码:

#include<stdio.h>
#include<string.h>
int map[105][105];
int visit[105];
int path[105];
int n,flag;
void dfs(int x,int step)
{path[step]=x;if(step==n){flag=1;return;}if(flag)return ;for(int i=1;i<=n;i++){if(map[x][i]==1 && visit[i]==0){visit[i]=1;dfs(i,step+1);if(flag)return ;visit[i]=0;}}
}
int main()
{int t,a,b;scanf("%d",&t);while(t--){flag=0;memset(path,0,sizeof(path));scanf("%d",&n);int m=n*(n-1)/2;memset(map,0,sizeof(map));memset(visit,0,sizeof(visit));for(int i=0;i<m;i++){scanf("%d%d",&a,&b);if(map[b][a]==0)map[a][b]=1;}for(int i=1;i<=n;i++){visit[i]=1;dfs(i,1);if(flag){for(int j=1;j<n;j++)printf("%d ",path[j]);printf("%d\n",path[n]);break;}visit[i]=0;}if(flag==0)printf("Impossible\n");}return 0;
}


 

  相关解决方案