题目:POJ-1753
http://poj.org/problem?id=1753
Flip Game
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 50214 | Accepted: 21262 |
Description
Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
Consider the following position as an example:
bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:
bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.
- Choose any one of the 16 pieces.
- Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).
Consider the following position as an example:
bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:
bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.
Input
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).
Sample Input
bwwb bbwb bwwb bwww
Sample Output
4
Source
Northeastern Europe 2000
解题思路一(DFS):
利用DFS的方法遍历所有棋子
每个棋子只有两种可能,翻与不翻,进而进行两个方向的深度优先搜索,并同时更新最小步数
#include <iostream>
#include <stack>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;char s;
int map[5][5];
int ans=9999999;bool judge() {int x=map[0][0];for (int i=0;i<4;++i)for (int j=0;j<4;++j) if(map[i][j]!=x) return 0;return 1;
}void flip(int i,int j) {map[i][j]=!map[i][j];if(i-1>=0) map[i-1][j]=!map[i-1][j];if(i+1<4) map[i+1][j]=!map[i+1][j];if(j-1>=0) map[i][j-1]=!map[i][j-1];if(j+1<4) map[i][j+1]=!map[i][j+1];
}void DFS(int x,int y,int t) {if(judge()) {if (ans>t) ans = t;
// cout<<"----------"<<ans<<endl;return;}if(x>=4||y>=4) return;int nx,ny;nx=(x+1)%4; ny=y+(x+1)/4; //顺序遍历 flip(x,y);DFS(nx,ny,t+1);flip(x,y);
// cout<<x<<","<<y<<endl;DFS(nx,ny,t); return;
}int main()
{for (int i=0;i<4;++i) {for (int j=0;j<4;++j) {cin>>s;if(s=='w') map[i][j]=1;else if(s=='b') map[i][j]=0; }}DFS(0,0,0);if (ans==9999999) cout<<"Impossible"<<endl;else cout<<ans<<endl;return 0;
}
解法思路二(BFS):
略