当前位置: 代码迷 >> 综合 >> POJ2034 Anti-prime Sequences dfs+合数判断
  详细解决方案

POJ2034 Anti-prime Sequences dfs+合数判断

热度:95   发布时间:2024-01-12 20:57:13.0

题目链接:This is the link

 

Anti-prime Sequences

Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 4129   Accepted: 1859

Description

Given a sequence of consecutive integers n,n+1,n+2,...,m, an anti-prime sequence is a rearrangement of these integers so that each adjacent pair of integers sums to a composite (non-prime) number. For example, if n = 1 and m = 10, one such anti-prime sequence is 1,3,5,4,2,6,9,7,8,10. This is also the lexicographically first such sequence. 

We can extend the definition by defining a degree danti-prime sequence as one where all consecutive subsequences of length 2,3,...,d sum to a composite number. The sequence above is a degree 2 anti-prime sequence, but not a degree 3, since the subsequence 5, 4, 2 sums to 11. The lexicographically .rst degree 3 anti-prime sequence for these numbers is 1,3,5,4,6,2,10,8,7,9. 

Input

Input will consist of multiple input sets. Each set will consist of three integers, n, m, and d on a single line. The values of n, m and d will satisfy 1 <= n < m <= 1000, and 2 <= d <= 10. The line 0 0 0 will indicate end of input and should not be processed.

Output

For each input set, output a single line consisting of a comma-separated list of integers forming a degree danti-prime sequence (do not insert any spaces and do not split the output over multiple lines). In the case where more than one anti-prime sequence exists, print the lexicographically first one (i.e., output the one with the lowest first value; in case of a tie, the lowest second value, etc.). In the case where no anti-prime sequence exists, output 

No anti-prime sequence exists. 

Sample Input

1 10 2
1 10 3
1 10 5
40 60 7
0 0 0

Sample Output

1,3,5,4,2,6,9,7,8,10
1,3,5,4,6,2,10,8,7,9
No anti-prime sequence exists.
40,41,43,42,44,46,45,47,48,50,55,53,52,60,56,49,51,59,58,57,54

Source

East Central North America 2004

题目大意:

输入m, n, d。求出m,m+1,m+2,````m+n的一个排列。使得任意的连续k个数之和都为合数,2<=k<=d。

输出,按照顺序输出排列,不能组成输出“No anti-prime sequence exists.”

This is the link

#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include <iomanip>
#include<list>
#include<map>
#include<queue>
#include<sstream>
#include<stack>
#include<string>
#include<set>
#include<vector>
using namespace std;
#define PI acos(-1.0)
#define EPS 1e-8
#define MOD 1e9+7
#define LL long long
#define ULL unsigned long long     //1844674407370955161
#define INT_INF 0x7f7f7f7f      //2139062143
#define LL_INF 0x7f7f7f7f7f7f7f7f //9187201950435737471
const int dr[]={0, 0, -1, 1, -1, -1, 1, 1};
const int dc[]={-1, 1, 0, 0, -1, 1, -1, 1};
// ios.sync_with_stdio(false);
// 那么cin, 就不能跟C的 scanf,sscanf, getchar, fgets之类的一起使用了。
const int N=10005;
int not_prime[N+5];
vector<int > prime;
int num[1005];
int v[1005];
bool falg;
int n,m,d;
void Isprime()
{not_prime[0]=not_prime[1]=true;prime.clear();for(int i=2;i<=N;++i){if(!not_prime[i])prime.push_back(i);for(int j=0;j<prime.size()&&i*prime[j]<=N;++j){not_prime[i*prime[j]]=true;if(!(i%prime[j]))break;}}
}
bool judge(int k,int d)
{for(int i=d;i>=2;--i){if(k-i>=0){int ans=0;for(int j=k-i+1;j<=k;++j)ans+=num[j];if(!not_prime[ans])//表示为素数return false;}}return true;
}
void dfs(int k)
{if(falg)return ;if(k==m-n+2){printf("%d",num[1]);for(int i=2;i<=m-n+1;++i)printf(",%d",num[i]);printf("\n");falg=true;return ;}for(int i=n;i<=m;++i){if(v[i]){num[k]=i;if(judge(k,d)){v[i]=false;dfs(k+1);v[i]=true;}}}
}
int main()
{Isprime();while(scanf("%d%d%d",&n,&m,&d)!=EOF){if(!n&&!m&&!d)break;memset(v,true,sizeof(v));falg=false;dfs(1);if(!falg)printf("No anti-prime sequence exists.\n");}return 0;
}

 

  相关解决方案