当前位置: 代码迷 >> 综合 >> HDU--dp练习--1022--Common Subsequence
  详细解决方案

HDU--dp练习--1022--Common Subsequence

热度:60   发布时间:2024-01-12 14:32:47.0

题目:

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 


Sample Input
abcfbc abfcab programming contest abcd mnp


Sample Output
4 2 0
题目大意:

就是求两个字符串的最长公共子序列。

解题思路:

LCS问题。

状态转移方程:

dp[i][j] = dp[i - 1][j - 1] + 1; a[i - 1] == b [j - 1]

dp[i][j] = max (dp[i - 1][j],dp[i][j - 1]);  a[i - 1] == b [j - 1]

参考博客:http://blog.csdn.net/dq_dm/article/details/45043689

源代码:

#include <bits/stdc++.h>
using namespace std;
int main()
{
    string a,b;
    while (cin >> a >> b)
    {
        int length_a = a.length();
        int length_b = b.length();
        int dp[length_a+1][length_b+1];
        int i,j;
        for (i = 0; i <= length_a; i++)
            dp[i][0] = 0;
        for (i = 0; i <= length_b; i++)
            dp[0][i] = 0;
        for (i = 1; i <= length_a; i++)
            for (j = 1; j<= length_b; j++)
            {
                if (a[i - 1] == b [j - 1])
                    dp[i][j] = dp[i - 1][j - 1] + 1;
                else
                    dp[i][j] = max (dp[i - 1][j],dp[i][j - 1]);
            }
   //     for (i = 0; i <= length_a; i++)
     //   {
       //     for (j = 0; j <= length_b; j++)
         //       cout << dp[i][j] << " " ;
           // cout << endl;
       // }
        cout << dp[length_a][length_b] << endl;
    }
    return 0;
}

  相关解决方案