当前位置: 代码迷 >> 综合 >> PAT_A 1032.Sharing(25)==未完待续
  详细解决方案

PAT_A 1032.Sharing(25)==未完待续

热度:58   发布时间:2024-01-11 13:39:52.0

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, “loading” and “being” are stored as showed in Figure 1.

Figure 1
You are supposed to find the starting position of the common suffix (e.g. the position of “i” in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output “-1” instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1

  • 分析:不就是个共享尾串嘛!为什么最后一个没有通过呢?

    • 注意相同字母,地址也会不同,相同的这是在共享尾串里的字母。
  • code:23`

#include<iostream>
#include<vector>
#include<cstdlib>
#include<cstdio>
using namespace std;
vector<int> a;
vector<int> b;
int count[100010];
int main()
{fill(count,count+100010,0);//freopen("1032.in","r",stdin);int tmp_a,tmp_b,size;scanf("%d%d%d",&tmp_a,&tmp_b,&size);char tmp_s[10];int flag=-1;count[tmp_a]=1;count[tmp_b]=1;if(tmp_a==tmp_b)flag=tmp_a;int count_1=0;for(int i=0;i<size;i++){scanf("%d%s%d",&tmp_a,tmp_s,&tmp_b);if(tmp_b!=-1){if(count[tmp_b]==1){flag=tmp_b;}count[tmp_b]=1;}}if(flag==-1)printf("-1\n");elseprintf("%05d\n",flag);return 0;
}
  • 23

  • 别人的代码

#include<iostream>
#include<vector>
#include<cstdlib>
#include<cstdio>
using namespace std;
vector<int> a;
vector<int> b;
int count[100010];
int list[100010];
int main()
{fill(count,count+100010,0);fill(list,list+100010,-1);//freopen("1032.in","r",stdin);int tmp_a,tmp_b,size;scanf("%d%d%d",&tmp_a,&tmp_b,&size);char tmp_s[10];int flag=-1;int start_a=tmp_a;int start_b=tmp_b;if(tmp_a==tmp_b)flag=tmp_a;for(int i=0;i<size;i++){scanf("%d%s%d",&tmp_a,tmp_s,&tmp_b);list[tmp_a]=tmp_b;}while(start_a!=-1){count[start_a]=1;start_a=list[start_a];}while(start_b!=-1){if(count[start_b]==1){flag=start_b;break;}start_b=list[start_b];}if(flag==-1)printf("-1\n");elseprintf("%05d\n",flag);return 0;
}
  • 25
  相关解决方案