Red and Black//POJ - 1979//dfs
题目
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
…#.
…#
…
…
…
…
…
#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.
…
11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0
Sample Output
45
59
6
13
题意
与@连起来的点的数量
链接:http://poj.org/problem?id=1979
思路
dfs模板题。
代码
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <string>using namespace std;
char s[50][50];
int cnt=0;
int l[4]={
-1,0,1,0};
int r[4]={
0,1,0,-1};
void dfs(int i,int j){
if(s[i][j]=='#') return;else if(s[i][j]=='.'||s[i][j]=='@') {
cnt++;s[i][j]='#';for(int t=0;t<4;t++){
if(i+l[t]>=0&&j+r[t]>=0)dfs(i+l[t],j+r[t]);}}
}
int main()
{
int n,m;while(1){
cin>>m>>n;if(m==0&&n==0) break;memset(s,0,sizeof(s));for(int i=0;i<n;i++){
scanf("%s",s[i]);}cnt=0;for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
if(s[i][j]=='@'){
dfs(i,j);goto A;}}}A:cout<<cnt<<endl;}return 0;
}